5.4 Headless Installation from FreeBSD Disk 1?

Martin McCormick martin at dc.cis.okstate.edu
Thu Aug 4 16:36:18 GMT 2005

	I am attempting to install FreeBSD5.4 on a Dell Poweredge 1850
via the serial console.  I went through the documentation again and
found the following  on the FreeBSD 5.4 documentation in installation-i386.txt

FreeBSD/i386 5.4-RELEASE Installation Instructions

---------- snip  ----------

1.5.6 Tips for Serial Console Users

   If you'd like to install FreeBSD on a machine using just a serial port
   (e.g. you don't have or wish to use a VGA card), please follow these
    1. Connect some sort of ANSI (vt100) compatible terminal or terminal
       emulation program to the COM1 port of the PC you are installing
       FreeBSD onto.
    2. Unplug the keyboard (yes, that's correct!) and then try to boot
       from floppy or the installation CDROM, depending on the type of
       installation media you have, with the keyboard unplugged.
    3. If you don't get any output on your serial console, plug the
       keyboard in again. If you are booting from the CDROM, proceed to
       step 5 as soon as you hear the beep.
    4. If booting from floppies, when access to the disk stops, insert
       the first of the kernX.flp disks and press Enter. When access to
       this disk finishes, insert the next kernX.flp disk and press
       Enter, and repeat until all kernX.flp disks have been inserted.
       When disk activity finishes, reinsert the boot.flp floppy disk and
       press Enter.
    5. Once a beep is heard, hit the number 6, then enter
boot -h
       and you should now definitely be seeing everything on the serial
       port. If that still doesn't work, check your serial cabling as

---------- snip -----------

	According to that, the CDROM still has the headless option.
On this particular server as well as all the other FreeBSD boxes we
presently run, removing the keyboard causes the BIOS to indicate a
non-functional keyboard but the FreeBSD boot engine doesn't get the
message so we always had to have a keyboard in the past in order to type

boot -h

and that did get the serial console going, often-times at 115,200
baud, but nonetheless going.

	On 5.4, I made several attempts both with and without the
keyboard and never got a beep.  I got a monitor and a coworker who can
see said monitor to watch the video output and we tried again both
with and without a keyboard.  Both times, it goes right to a GUI
without any opportunity to do anything except watch it boot.

	I see that the 5.4-RELEASE-i386-bootonly.iso
and the 5.4-RELEASE-i386-disc1.iso images are both bootable.  I figure
I need disk1 to install with.

	I am sorry for the length of this message but I wanted to
demonstrate that we have made every effort to make sure this wasn't
just operator error on my part.

	Any ideas as to how to get this headless installation going
with the CDROM are much appreciated.  I am replacing one of our DNS's
that fried a few weeks ago and we are running on the backup, only
until I can get something working again.  Many thanks.

Martin McCormick WB5AGZ  Stillwater, OK 
OSU Information Technology Division Network Operations Group

More information about the freebsd-questions mailing list