hard drive not properly dismounted

Bryan Maynard bryan.maynard at reallm.com
Tue Aug 2 22:10:04 GMT 2005

On Tuesday 02 August 2005 08:08 pm, dwinner-lists at att.net wrote:
>I have a second hard drive in my docking station that gets mounted at
> each boot as /hd2.
>For the  past few weeks, everytime I boot, I get the message
>"/hd2 not properly dismounted"
>I have a script in /usr/local/etc/rc.d that automatically mounts and
> unmounts /hd2 at boot and shutdown.
>Also, if I just unmount /hd2 manually, I still get that message.
>I've run fsck on it, can still access when booted, and don't see
> anything wrong.
>Why am I getting that message?

If the laptop (or docking station) lost power or was forcably powered 
off the drive will be left in an inconsistant state - causing the error 
message you're seeing.

I have had this happen to me a few times. I booted into single-user mode 
by entering "boot -s" at the boot countdown (after pressing "space"). 
Once the system is up (and before I mount any drives) I run "fsck -y". 
This runs fsck and answers "yes" to all questions. Check the man-page 
for all availible options. If you want to run fsck interactively, leave 
"-y" off.

>Any ideas?

Hope that helps :-D



Open Source: by the people, for the people.

More information about the freebsd-questions mailing list