libusb, gphoto2, sony dsc-t1

Frank Glerkin fglerk at
Thu Sep 30 19:00:15 PDT 2004

Hi everyone,

I'm experiencing some problems getting my digital camera (Sony Cybershot 
DSC-T1) to
interface with the USB system under FreeBSD RELENG_5.

I've tried setting my camera into normal mode and tried to use it as a umass 
device, but no /dev/da* device is created so there's nothing for me to 
mount. umass0 entry is created though.

Setting my camera to PTP mode, I tried using gphoto2 to get pictures, or 
even just simply listing the files on the camera, fails with operation timed 
out. The offending portion being

0.109944 gphoto2-port(2): Setting timeout to 8000 millisecond(s)...
0.110027 ptp(2): PTP: Opening session
0.110083 gphoto2-port(2): Writing 16=0x10 byte(s) to port...
0.110139 gphoto2-port(3): Hexdump of 16 = 0x10 bytes follows:
0000  10 00 00 00 01 00 02 10-00 00 00 00 01 00 00 00  ................

0.114318 gphoto2-port(2): Reading 512=0x200 bytes from port...
gp_port_read: Operation timed out
8.128040 PTP2/library.c(2): PTP: gp_port_* function returned 0xffffffde      
8.128085 context(0): PTP I/O error

*** Error ***
PTP I/O error
8.128114 gphoto2-port(2): Closing port...
8.128240 context(0): An error occurred in the io-library ('Unspecified 
error'): No error description available

*** Error ***
An error occurred in the io-library ('Unspecified error'): No error 
description available
*** Error (-1: 'Unspecified error') ***

I've read on google and other places where this has been resolved for some 
cameras, but it doesn't seem to work with mine. I'm willing to help debug 
the code. I've tried looking into the file bsd.c that comes with libusb and 
found that gphoto2 stalls around the place where the read takes place 
(obvious). I'm not really sure what else to check since it's writing and 
it's being accepted by the camera, but the read is just failing. I'm 
inclined to think it's a USB issue since gphoto2 sends the exact same bytes 
to the camera on my linux machine and it works perfectly there.

I have

Thanks all,


Is your PC infected? Get a FREE online computer virus scan from McAfee® 

More information about the freebsd-questions mailing list