a very annoying pb with accounts

Steve Hodgson steve at acidy.com
Thu Sep 30 07:25:24 PDT 2004

owner-freebsd-questions at freebsd.org wrote:
> Hi everybody,
> Here is my (weird) problem ...
> I opened /etc/spwd.db with ee and exited (which was actually
> a very bad
> idea, even if I did not modified anything). At this time, everything
> was still ok.
> Then, a few minutes later, I tried to su ... Impossible : I get some
> weird error message telling me "su: who are you ?"
> Then I tried to log directly from the login shell on tty0 with my
> account... unknown user. I add a look at /etc/passwd : everything was
> correct. 
> And when I tried to recreate my account : "user already
> exists" Then I reboot (the second very bad idea in the same
> day), and user "gdm"
> didn't exist anymore.
> Exactly as if I forgot to make mergemaster after upgrading, but with
> only one difference : I actually didn't made a upgrade.
> So now the situation is : I can only access with root
> account. Does someone know when I did a mistake ? and does
> someone knows how to
> fix it ? Should I delete account in /etc/passwd and create
> them again ?
> I had this idea, but I didn't want to make another stupid
> thing today :) Thanks a lot

I can only guess that you need to use pwd_mkdb. Probably the easiest way to
do this is to use /sbin/vipw, just doing ":wq" to save the changes (though
there will be none), which will run pwd_mkdb for you.


More information about the freebsd-questions mailing list