COM port problems p5mvp3-at

Andrew andrew at
Wed Sep 29 12:22:16 PDT 2004


I am having some trouble with the COM ports on a ESA motherboard; model
# P5MVP3-AT "Viking".
Issues are:
1.  With modem hooked up (via 9 pin D) to COM1 (/dev/cuaa0) the command
"cu -l/dev/cuaa0 -s57600" does not communicate with the modem.
2.  /sbin/dmesg output reveals that sio0 and sio1 are "identified", at
the correct port (according to the BIOS settings), and are on the
correct irq.  The type of the device is 16550A.
3.  device sio has been compiled into the kernel and cuaa0 and cuaa1 are
in the /dev directory.
4.  I can remove the external modem and put in an old US Robotics
internal ISA modem configured with the jumpers to COM1 and the command
"cu -l/dev/cuaa0 -s57600" works fine.  In order for me to put in the ISA
modem into the system I have to disable COM1 settings in the BIOS (the
port number) or there is a conflict message at BIOS boot time.  When I
remove the ISA modem and hook the external modem back up to the system
via 9 pin D cable the external modem still does not work.
5.  BIOS has been updated.
6.  Default BIOS settings have been tried along with alternate settings.
7.  I know the modem works because I can hook it up to my Windows
machine and connect to the internet.
8.  I had the modem hooked up to a previous FreeBSD machine that was
acting as a gateway and the modem worked fine.

So, basically with BIOS set to default settings everything "seems" to be
set up correctly but for some reason the modem does not work.

Is this the appropriate list for help?

Andrew Carroll
andrew at

More information about the freebsd-questions mailing list