Cannot update XFree86-4

knowtree at knowtree at
Thu Sep 23 12:28:10 PDT 2004

> On Tue, Sep 21, 2004 at 05:10:00PM -1000, Gary Dunn wrote:
> > It started with a bug-fix update to one part of XFree86. After I
> > installed it, my Gnome panel refused to load some applets. As the Gnome
> > desktop opens I get error dialogs like these:
> > 
> <SNIP>
> > 
> > I ran pkg_version and noticed that all of XFree86 had newer versions,
> > from 4.2 to 4.4. I thought I was out of whack and just needed to update
> > the whole thing. I did portupgrade XFree86, but it failed here:
> If sucha command fails then this is sometimes because the packages that
> it relies on also needs to be rebuild. Try portupgrade -fR XFree86\*
> <SNIP>
> > =-=-=-=-=
> > 
> > I googled this and found one previous posting in August, but no reply. 
> > 
> > I updated my ports and 4.10 STABLE source trees and rebuilt my kernel,
> > but that did not help.
> It shoudn't
> > 
> > Does it matter that my sources are on an NFS server and I only mount one
> > at a time (/usr/ports or /usr/src)?
> No its not a problem for as far as i can see. It would be handy to have
> you working directory localy (can be set by /etc/make.conf). This speeds up
> things.
> -- 
> Alex

Thanks for the help. I went ahead yesterday and hacked away for awhile, and
worked around the problem. The reason I was nervous about those portupgrade
flags is that in the past portupgrade has made a mess of things, doing too
much at a time, and they are not mentioned in the note in the XFree86-4
port. I figured, if it needed those dependency checks it would have said
so. Too conservative?

The first fix was a dependency on /usr/X11R6/lib/X11/doc/ddx.txt which
always failed because the file extension is is caps -- ddx.TXT. I made a
link so both versions were there and got past that point.

The second fix solved a problem building fonts, where one of the make files
was trying to run perl with a program called ucs2any. This stopped with
"Unrecognized character \177 at /usr/X11R6/bin/ucs2any line 1."  On my
system, that file is a binary; there is a in the same directiry.
I renamed the bin and linked the .pl to the no -extension version, and the
fonts built perfectly.

Now I'm working through my pkg_version report, and everything sems to be fine.

Thanks again; maybe I'll have the nerve to try that next time.

Gary Dunn

More information about the freebsd-questions mailing list