Port upgrading - my way

Curtis Vaughan curtis at npc-usa.com
Tue Sep 21 14:43:16 PDT 2004

OK, I took Donald on with his test and this is what I got:

Here's my INDEX-5 info before running portversion

4947853 Mar 15  2004 INDEX-5

and here it is after

5804696 Sep 21 13:54 INDEX-5

So, a definite change.
And when I ran portversion -vL= the first time, I got the info provided 
immediately below. But the second time I ran portversion -vL= there was 
not output. So, what exactly does that mean? and does that mean that 
now I should run portupgrade -a now?

apache-1.3.31_6             >  succeeds port (port has 1.3.29_3)
bandwidthd-1.2.1            >  succeeds port (port has 1.2.0_1)
bash-2.05b.007_2            >  succeeds port (port has 2.05b.007)
bsdiff-4.2                  >  succeeds port (port has 4.1)
expat-1.95.8                >  succeeds port (port has 1.95.7)
ezm3-1.2                    >  succeeds port (port has 1.1_1)
freebsd-update-1.6          >  succeeds port (port has 1.5)
freetype2-2.1.7_3           >  succeeds port (port has 2.1.5_2)
gd-2.0.25,1                 >  succeeds port (port has 2.0.15_1,1)
jpeg-6b_3                   >  succeeds port (port has 6b_1)
libiconv-1.9.2_1            >  succeeds port (port has 1.9.1_3)
libtool-1.5.8               >  succeeds port (port has 1.5.2_1)
m4-1.4.1                    >  succeeds port (port has 1.4_1)
openldap-client-2.2.15      >  succeeds port (port has 2.2.6)
p5-Net-SSLeay-1.25          >  succeeds port (port has 1.23)
pam_ldap-1.7.1_1            >  succeeds port (port has 1.6.7_1)
perl-5.8.5                  >  succeeds port (port has 5.8.2_5)
png-1.2.6                   >  succeeds port (port has 1.2.5_3)
popt-1.7                    >  succeeds port (port has 1.6.4_2)
portupgrade-20040701_3      >  succeeds port (port has 20040208)
postfix-2.1.4,1             >  succeeds port (port has 2.0.18,1)
rsync-2.6.2_3               >  succeeds port (port has 2.6.0)
ruby-1.8.2.p2_1             >  succeeds port (port has 1.8.1_2)
samba-2.2.11_1              >  succeeds port (port has 2.2.8a_1)
sudo-                >  succeeds port (port has
unzip-5.51                  >  succeeds port (port has 5.50_2)
webmin-1.150_5              >  succeeds port (port has 1.130_10)

On 21 Sep, 2004, at 12:22, Donald J. O'Neill wrote:

> On Tuesday 21 September 2004 12:40 pm, Curtis Vaughan wrote:
>   I just want to know whether there is any reason I
>> shouldn't be doing it this way. In other words, by doing it this
>> way is there a potential problem or error that my result?
> <<<<<<<<<<<<<<<<<>>>>>>>>>>>>>>>>>>>
> Yes, there is. As far as I can tell from what you've given, you're
> depending on INDEX-5 to be up to date after your ports upgrade. I
> don't believe it is and you need to run make index or some other
> means of getting INDEX-5 to be up to date..
> Try this experiment:
> cvsup your ports
> note the date and size of /usr/ports/INDEX-5
> run " portversion -vL=" or portversion -rRvc
> keep track of that output
> now cd /usr/ports
> make index
> note the date and size of INDEX-4
> run portversion -vL= or portverstion -rRvc
> I think you'll see a lot more of your installed stuff needs
> updating.
> Don
> -- 
> Donald J. O'Neill
> donaldj1066 at fastmail.fm
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list