vinum software raid as boot drive

Bruce Harding bdh at
Mon Sep 20 14:13:24 PDT 2004

We are currently trying to set up server with software raid using vinum 
on 5.3.  We plan to use it as a Mirrored root filesystem So far we have 
followed Greg Lehey's instructions from

and the handbook on vinum:

note we are only using a single / partition.

output of bsdlabel:

#        size   offset    fstype   [fsize bsize bps/cpg]
   a: 141315997  2048000    4.2BSD     2048 16384 28552
   b:  2047719      281      swap
   c: 143363997        0    unused        0     0         # "raw" part, 
don't edit
   h: 143363981       16     vinum

vinum Description File

drive rootdev device /dev/da0s1h

volume root
   plex org concat
   sd len 141315997s driveoffset 2047984s drive rootdev

volume swap
   plex org concat
   sd len 2047719s driveoffset 265s drive rootdev

We could not find stated exactly anywhere, but we are presuming the 
description file that you use with vinum create becomes /etc/vinum.conf

When we execute vinum create it appears to work fine.  The Devices are 
created in /dev/vinum/ and we can do a fsck -n -t ufs /dev/vinum/root 
which outputs no errors

The problem is when we reboot the devices in /dev/vinum are destroyed ( 
presume this is normal behaviour ) but they are not created on boot.



Have also tried /boot/loader.conf with:


both with exactly the same result.  When booting we get the message

vinum: loaded
vinum: no drives found

any help much appreciated.

please cc me in replies.

More information about the freebsd-questions mailing list