ata1-slave: ATA identify retries exceeded

Nathan Kinkade nkinkade at
Fri Sep 17 07:56:32 PDT 2004

On Thu, Sep 16, 2004 at 05:55:27PM -0600, RYAN vAN GINNEKEN wrote:
> Keep getting this error in my dmesg
> ata1-slave: ATA identify retries exceeded
> this is for my cdrom drive and it is not working can someone give me 
> some hints on how to trouble shoot.  The jumpers are set right and i 
> have replace the cable but still get the error.  Here is the intire 
> dmseg dump

> ata0: at 0x1f0 irq 14 on atapci0
> ata1: at 0x170 irq 15 on atapci0

FreeBSD is at least seeing both controllers.

> ata1-slave: ATA identify retries exceeded
> ad0: 4120MB <Maxtor 84320D4> [8930/15/63] at ata0-master UDMA33
> ad2: 3832MB <QUANTUM Bigfoot TX4.0AT> [8306/15/63] at ata1-master UDMA33

How sure are you that the CDROM device is good?  Have you tried it in a
different machine?  One thing to do would be to take that Quantum drive
off the secondary controller and try the CDROM device alone on that
channel as the master device.  An incorrect cable or device setting
might affect the CDROM.  If that fails try the CDROM as the slave device
on the primary channel.  Test various combinations that will allow you
to be certain that the problem is not the controller, cable, or a
faulty device sharing the channel.  If you get the same error no matter
the configuration, then it's likely that the CDROM device is defective
in some way.  One other possibilty would be to boot the machine to a
LiveCD such as Knoppix and see if that OS has a problem identifying the
CDROM device.  If so, then there may be a problem in the interaction
between the FreeBSD driver and your particular device and/or hardware.
My guess, though, is that there may be something wrong with the CDROM
device itself.  Good luck ...

PGP Public Key:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list