Mouse problems

TomasSnäckerström Tomas.Snackerstrom at
Sun Sep 12 07:05:03 PDT 2004


My name is Tomas. I've recently installed FreeBSD and this is the first time 
ever that I install a UNIX system. I use Solaris at work but as said this is 
the first time for me as root.

Everything worked fine and I now have my file/printserver up and running. 
However a while ago I decided to add a graphical environment for convenience 
and that is when I ran into trouble.

My problem is that when I start X (Gnome or KDE) my PS/2 mouse goes bananas. 
Basically it moves in the inverse direction on both axises (up and right) and 
does not respont on movements down or left. (The pointer then ends down in the 
bottom left corner.) Buttons seem to work.

Here is what I know. I run BSD version 5.2.1, XFree86 and latest releases of 
Gnome/KDE. In the mousedeamon test program in found in the sysinstall program, 
the mouse works properly. If I start X and then exit it, the mouse is still 
activated and it works properly!

This is the reason I thought it might be related to Gnome but I get the same 
behaviour after installing KDE. I then add a plug and pray compatible USB 
mouse from logitech and it acts identically. (Yes I've tried different PS/2:s 
aswell, 2,3 buttons with or without scroll.)

According to documentation "auto" detection should work for all PS/2 mouses. 
XFree homepage states that the BSD mouse deamon should work fine. The XFree 
config says nothing that to me indicates problems. 

As I understand You've terminated cooperation with XFree but I doubt that a 
change to Xorg will solve this particular problem.

I have tried to find this problem on the web but failed, and now i really dont 
know where to go but to call you. 

Please tell me that I am just a stupid user who forgot to do something really 
trivial. I really like BSD so far and am very impressed with it. I'm working 
on contributing and am already trying to convince all my friends.

Thanx in advance

More information about the freebsd-questions mailing list