Sendmail 8.12.11 from FreeBSD 4.10-RELEASE ignores many config directives

Karl Swartz karl at
Tue Sep 7 13:20:26 PDT 2004

I just upgraded from Sendmail 8.12.3 (from FreeBSD 4.6) to a brand new
FreeBSD 4.10-RELEASE install including Sendmail 8.12.11.  I tweaked a
few pathnames in my .mc file but otherwise tried to use the same one.
Many things weren't working.  I've found workarounds for some, but they
are hacks, and others simply don't work.  I don't really know if this
is a sendmail problem or something weird about the FreeBSD port of it.

What follows is a list of what's broken.

FEATURE(dnsbl, `')
FEATURE(dnsbl, `')

   Yes, I'm a MAPS subscriber, DNS is working correctly, and I can query
   the various lists and get the expected answers back.  Addresses which
   are in one or more of the lists I have configured pass right through
   sendmail with nary a complaint.  I've yet to find any evidence that
   the check_relay rulesets are being called at all.  (I also have
   FEATURE(access_db, ...) enabled and this appears to be working.)

define(`confCW_FILE', `-o /etc/mail/')

   This has no effect, though I found that /etc/mail/local-host-names is
   being consulted so that's a viable workaround.  I didn't try removing
   the -o and I can't recall what that does, so perhaps that was the

define(`confTRUSTED_USERS', `majordom')

   This address the appropriate line to the .cf file, but sendmail seems
   to ignore it as evidenced by lines like

      X-Authentication-Warning: majordom set sender
              to owner-LIST at using -f

   in mail sent to Majordomo's lists.  So far this one seems to be
   harmless albeit annoying.

define(`ALIAS_FILE', `/etc/mail/aliases,/etc/mail/aliases.majordomo')

   The second alias file is ignored, and yes, I have built .db files
   for both of them.  As a workaround, I finally just lumped Majordomo's
   aliases into the main system file, but I'd rather keep them separate
   and the doccy says it should work.  I found something which said that
   m4 wants ``foo,bar'' with pairs of quotes if there's a comma but that
   made no difference.  The resulting line in the .cf file (which
   matched what worked in the old version) was the same in any case.


   It appears that this is being ignored.

What's going on?  I had hoped to close some holes with the upgrade but
at this point I'm about ready to dredge the sendmail 8.12.3 stuff out of
my backups and revert to that.  Any help in m akeing 8.12.11 match what
the documentation claims would be most appreciated.

 -- Karl

More information about the freebsd-questions mailing list