freebsd builds

Andrew tacoboy24 at
Fri Sep 3 04:39:26 PDT 2004


Building kernels I am comfortable with. I have been doing it a while for SUSE. 
Now I wanted to try freebsd 5.1.  So I have some questions about freebsd 
Some of the questions may sound dumb but I want to make sure I don't do 
something catostrophic based on a past experience with SUSE. So...

make clean - simply cleans objects, executables in the work area /usr/src. 
Nothing else

make buildkernel - simply builds the kernel, support modules, and so on in the 
work area only /usr/src. The biilt kernel is located in 

make installkernel - once this is done, that which was in the work area is 
placed in working directories of the installed system. 

For SUSE I used GRUB or lilo to write the boot block. For freebsd I use 

I am targeting the kernel for a Soekris 4511. The 4511 has a national 
semiconductor ethernet chip. On SUSE I add the configuration parameter 
NATSEMI=Y to build the ethernet driver. What is the configruation parameter 
for Freebsd ethernet driver.

I was reading a notes file on a technique of building a jail sandbox. The 
sandbox becomes something like freebsd inside freebsd. The purpose was to 
allow someone to make major modifications to the kernel and not affect the 
working operating system components.

Per the notes file, the sandbox is set by:

perform a customer install. 
During the install change the installation location to point to the sandbox.
chroot <sandbox>
Do a build in the sandbox

I create the folder, changed the destintation to be the sandbox in the 
installation options, and installed freebsd in the sandbox folder. Then I:

chroot to the sandbox

To verify my sandbox install was correct, I tried to rebuild the GENERIC 
kernel in the sandbox.

An error occured in makefile.inc1 line 139. That line has a make command 
dealing with CPUTYPE. The error was its value not being zero.

I then exited the sandbox (command shell) and reexecuted the make command to 
rebuild the GENERIC kernel in the standard /usr/src location. It worked fine. 
So it is not the installation kit.

The problem is something I have not  done or did improperly in creating the 
sandbox. Thoughts.


More information about the freebsd-questions mailing list