getting ssh to work

David Syphers dsyphers at
Fri Sep 3 01:23:16 PDT 2004

I recently tried to ssh into my desktop from another machine, and found that 
it doesn't work (it times out). I'm not sure what I need to do to make it 
work. I'm running 5-CURRENT from August 3 (back when 5 was still -CURRENT).

I've confirmed that sshd is running (sshd_enable="YES" is in rc.conf). I've 
checked /etc/ssh/sshd_config, and I haven't changed any of the defaults. My 
firewall should allow this sort of thing, and just to make absolutely sure, I 
told my firewall to (temporarily) let in _everything_ from the entire class B 
network the remote machine is on. netstat says that my machine is listening 
on port 22. And I can 'ssh localhost' from my desktop to itself (though it 
does say, "socket: Protocol not supported" before successfully asking for my 

The remote machine in question is running OpenSSH_3.6.1p2, and I'm running 
OpenSSH_3.8.1p1. I thought maybe for some odd reason ssh'ing out is blocked 
on the remote machine, but then I remembered that a friend tried to ssh in 
from his OS X laptop the other day, and that timed out the same way the 
current remote machine is. And I don't get a "Permission denied" sort of 
error on the remote machine, just a timeout.

Any ideas? Thanks,


+++ Divide By Cucumber Error. Please
Reinstall Universe And Reboot. +++

More information about the freebsd-questions mailing list