rl2 not working on otherwise functioning network/gateway

chris at voicesofopposition.org chris at voicesofopposition.org
Wed Sep 1 19:42:51 PDT 2004

Ok, if someone here can help me w/ this I will be really grateful. I
turned to this list after a post on a forum offering the expected advice
didn't help solve my problem. Basically my computer acts as a gateway for
my network, and it functions fine. I then decided to add another network
adapter so that I could add my file server to the network. But after
making the necessary changes to my rc.conf, I found that the network card
was "active", but had no IP address, and wasn't passing traffic. I'm
attaching my dmesg, and the output from ifconfig rl2. Here are a few
things I've tried to remedy the problem.

I tried swapping out the nic, disabling acpi, resetting the CMOS battery,
booting with the GNERIC kernel, and adding network information to th NIC

None of this helped. Anyway, like I said, the gateway functions for the
other computer on the network, so firewall and NATD are there. Here is all
the info

# ifcongfig rl2
inet6 fe80::240:5ff:fe7c:6e4c%rl2 prefixlen 64 scopeid 0x3
ether 00:40:05:7c:6e:4c
media: Ethernet autoselect (100baseTX <full-duplex> )
status: active

# dmesg
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 5.2.1-RELEASE #1: Fri Aug 6 06:35:44 MST 2004
Preloaded elf kernel "/boot/kernel/kernel" at 0xc0a8f000.
Preloaded elf module "/boot/kernel/acpi.ko" at 0xc0a8f1f4.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) Processor (1101.95-MHz 686-class CPU)
Origin = "AuthenticAMD" Id = 0x642 Stepping = 2
AMD Features=0xc0440000<RSVD,AMIE,DSP,3DNow!>
real memory = 536805376 (511 MB)
avail memory = 511762432 (488 MB)
Pentium Pro MTRR support enabled
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <VIA694 AWRDACPI> on motherboard
pcibios: BIOS version 2.10
Using $PIR table, 7 entries at 0xc00fde80
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
acpi_cpu0: <CPU> port 0x530-0x537 on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port
0x6000-0x607f,0x5000-0x500f,0x4080-0x40ff,0x4000-0x407f,0xcf8-0xcff on
pci0: <ACPI PCI bus> on pcib0
pcib0: slot 7 INTD is routed to irq 10
pcib0: slot 7 INTD is routed to irq 10
pcib0: slot 7 INTC is routed to irq 9
pcib0: slot 7 INTC is routed to irq 9
pcib0: slot 10 INTA is routed to irq 11
pcib0: slot 11 INTA is routed to irq 9
pcib0: slot 12 INTA is routed to irq 10
pcib0: slot 13 INTA is routed to irq 11
agp0: <VIA 82C8363 (Apollo KT133A) host to PCI bridge> mem
0xd0000000-0xd3ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pcib0: slot 1 INTA is routed to irq 11
pcib1: slot 0 INTA is routed to irq 11
pci1: <display, VGA> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 82C686A UDMA66 controller> port 0xc000-0xc00f at device 7.1
on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata0: [MPSAFE]
ata1: at 0x170 irq 15 on atapci0
ata1: [MPSAFE]
uhci0: <VIA 83C572 USB controller> port 0xc400-0xc41f irq 10 at device 7.2
on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xc800-0xc81f irq 10 at device 7.3
on pci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pcm0: <VIA VT82C686A> port 0xd400-0xd403,0xd000-0xd003,0xcc00-0xccff irq 9
at device 7.5 on pci0
pcm0: <Realtek ALC100 AC97 Codec>
pci0: <simple comms> at device 7.6 (no driver attached)
rl0: <RealTek 8139 10/100BaseTX> port 0xdc00-0xdcff mem
0xd9012000-0xd90120ff irq 11 at device 10.0 on pci0
rl0: Ethernet address: 00:30:bd:25:ea:17
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl1: <RealTek 8139 10/100BaseTX> port 0xe000-0xe0ff mem
0xd9010000-0xd90100ff irq 9 at device 11.0 on pci0
rl1: Ethernet address: 00:30:bd:22:18:c0
miibus1: <MII bus> on rl1
rlphy1: <RealTek internal media interface> on miibus1
rlphy1: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl2: <D-Link DFE-530TX+ 10/100BaseTX> port 0xe400-0xe4ff mem
0xd9011000-0xd90110ff irq 10 at device 12.0 on pci0
rl2: Ethernet address: 00:40:05:7c:6e:4c
miibus2: <MII bus> on rl2
rlphy2: <RealTek internal media interface> on miibus2
rlphy2: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pci0: <simple comms> at device 13.0 (no driver attached)
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> port
0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio1 port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0 port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
orm0: <Option ROM> at iomem 0xc0000-0xca7ff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1101952323 Hz quality 800
Timecounters tick every 10.000 msec
ipfw2 initialized, divert enabled, rule-based forwarding enabled, default
to deny, logging disabled
acpi_cpu: throttling enabled, 2 steps (100% to 50.0%), currently 100.0%
GEOM: create disk ad0 dp=0xc4920b60
ad0: 57241MB <WDC WD600JB-00CRA1> [116301/16/63] at ata0-master UDMA66
acd0: DVDROM <ATAPI 12X DVDROM> at ata1-master PIO4
acd1: CDRW <ARTEC WRR-52X 1.20 20030318> at ata1-slave PIO4
Mounting root from ufs:/dev/ad0s1a
psmintr: delay too long; resetting byte count

More information about the freebsd-questions mailing list