Installing on Compaq DL380 with IDA RAID

Olaf Hoyer ohoyer at
Wed Sep 1 01:41:55 PDT 2004

On Tue, 31 Aug 2004, Doug Poland wrote:

> Hello,
> I'm having a problem installing 5.3-BETA2 on this box with a Compaq
> Integrated SMART Array Controller.  The install CD detects the array
> and I can partition, label, and install 5.3-BETA2 through the post-
> install configuration.  However, when I reboot, the OS tells me,
> something to the effect, "OS not found".


I assume you have the Generation1 of the DL380 running, white case, dual
Slot1 CPUs up to ~800MHz, 4U chassis, 4HDD available.

The smartarray SCSI Controller sits on a dedicated PCI card,
Configuration of that puppy is made via the Compaq Smartstart CD.

> I've tried installing the FreeBSD boot manager, a standard boot
> record, and to leave the MBR untouched.  I've also tried 4.9-RELEASE
> just to see if there was a problem with 5.3-BETA2.  No matter what
> I try, I cannot get the Compaq BIOS to recognize the OS I just
> installed on the drive array.

I had a machine with FreeBSD 4.8-R happily doing netsaint monitoring for
some months, so we can assume that there are some settings wrong.

Clasical candidates for this are:
OS Type in BIOS (respectively the corresponding part to be set up via
Smartstart CD) should be set to NT 4.0, at least this worked for me.
I had the HDD set up as RAID 1, after that I installed 4.8-R from CD as
the only OS on that HDDs.

Try swapping your PCI cards into different slots, its some known issue
regarding PCI Interrupt routing on those Compaq designs.

Olaf Hoyer        ohoyer at
Fuerchterliche Erlebniss geben zu raten,
ob der, welcher sie erlebt, nicht etwas Fuerchterliches ist.
(Nietzsche, Jenseits von Gut und Boese)

More information about the freebsd-questions mailing list