atacontrol and SATA RAID

Giovanni P. Tirloni gpt at
Thu Oct 28 07:32:58 PDT 2004


  I've a Intel SE7210TP1 motherboard with Adaptec HostRAID and I've 
created a RAID1 array with 2 SATA disks using the following command:

   atacontrol create RAID1 ad4 ad6

  The system installed on /dev/ar0 just fine and I played a bit with 
atacontrol detaching and attaching the disks.

  Detaching ad6 worked without problems with the following commands:

   atacontrol detach 3
   atacontrol attach 3
   atacontrol rebuild 0

  But when I tried to detach ad4 (after rebuilding array from previous 
detachment) I got an error saying the array was broken. Now when 
booting it shows this:

  ar0: 152627MB <ATA RAID1 array> [19457/255/63] status: DEGRADED 
     disk0 READY on ad4 at ata2-master
     disk1 DOWN no device found for this disk

  but atacontrol list shows ad6 there. So my question is: what's the 
proper way of doing de attach/detach operation ?

Giovanni P. Tirloni

PS.: Please CC me any reply because I'm not subscribed to questions@ 

More information about the freebsd-questions mailing list