portversion / ruby is broken after updating ports

Kent Stewart kstewart at owt.com
Sun Oct 3 12:35:10 PDT 2004

On Sunday 03 October 2004 11:45 am, robg wrote:
> I update my ports every couple of days, and there were only a small
> amount today that needed to be updated, so I ran the cvsup to update
> ports file
> I then typed `portsdb -Uu` and this came up:
> server# portsdb -Uu
> Updating the ports index ... Generating INDEX.tmp - please wait..***
> Error code 1
> 1 error

When I did a cvsup of ports-all, what I saw on a make index was the following

# make index
Generating INDEX - please wait..test: <: unexpected operator
Warning: Duplicate INDEX entry: freeciv-gtk2-1.14.1
Warning: Duplicate INDEX entry: fvwm-imlib-2.4.18

It appears that "make index", which is what portsdb -U runs, doesn't like your 
setup. Do you have any ports that you refuse.

> ********************************************************************
> Before reporting this error, verify that you are running a supported
> version of FreeBSD (see http://www.FreeBSD.org/ports/) and that you
> have a complete and up-to-date ports collection.  (INDEX builds are
> not supported with partial or out-of-date ports collections -- in
> particular, if you are using cvsup, you must cvsup the "ports-all"
> collection, and have no "refuse" files.)  If that is the case, then
> report the failure to ports at FreeBSD.org together with relevant
> details of your ports configuration (including FreeBSD version,
> your architecture, your environment, and your /etc/make.conf
> settings, especially compiler flags and WITH/WITHOUT settings).
> Note: the latest pre-generated version of INDEX may be fetched
> automatically with "make fetchindex".
> ********************************************************************
> *** Error code 1
> Stop in /usr/ports.
> *** Error code 1
> Stop in /usr/ports.
> failed to generate INDEX!
> portsdb: index generation error
> server#
> so I tried to run `portversion` and this came up:
> server# portversion
> [Updating the portsdb <format:bdb1_btree> in /usr/ports ... - 11735
> port entries found .........100
> 0.........2000.........3000.........4000.........5000.........6000.........
>7000.........8000..../us r/local/lib/ruby/site_ruby/1.8/portsdb.rb:587:
> [BUG] Segmentation fault ruby 1.8.2 (2004-07-29) [i386-freebsd5]
> Abort (core dumped)
> server#
> What can I do? Why is ruby doing this now?

Since "make index" died, it is anybodys guess. When all of the problems 
occured, I added the following to /usr/local/etc/pkgtools.conf

  ENV['PKG_DBDRIVER'] = "bdb_hash"
  ENV['PORTS_DBDRIVER'] = "bdb_hash"

I thought this problem was fixed but I was only vacation during that time and 
my email machine had a HD crash. Webmail didn't let me sort things out :).


> Thanks.

Kent Stewart
Richland, WA


More information about the freebsd-questions mailing list