VMWare 2 works on FreeBSD 4.10-Stable (except for NIC)

bsdfsse bsdfsse at optonline.net
Sat Oct 2 11:33:49 PDT 2004

I have everything working except for the networking (which is proving to 
be very difficult).

I followed Phusion's guide for VMWare 2 and FreeBSD 4.10 located here:


Previously I had tried 4.10, but I think at that time I was erroneously 
entering "vmnet1" in to the NIC config, instead of "/dev/vmnet1".  I was 
also getting ATA errors on that particular machine's 200GB drives, which 
is prolly a completely different problem.

My Win 2000 Pro virtual machine can ping itself, but not the host 
machine, or any of my other LAN machines.  Christian emailed me some 
instructions that differ from Phusion's regarding the configuration of 
the /usr/local/etc/vmware/config file.  Christian has these 2 lines 
while Phusion does not (and I tried it both ways):

   vmnet1.Bridged = "YES"
   vmnet1.BridgedInterface = "x10"

Phusion does mention the "x10" in his instructions for the /etc/rc.firewall.

My IP setting are:

  Linksys Router:

  FreeBSD 4.10-Stable PC
   Static IP:
   DNS Server:

  VMWare /usr/local/etc/vmware/config:
   vmnet1.HostOnlyAddress = ""
   vmnet1.HostOnlyNetMask = ""
   (also from Christian's doc)
   vmnet1.Bridged = "YES"
   vmnet1.BridgedInterface = "x10"

  Win2000 Pro Virtual PC
   Static IP:

I made the changes to my kernel, /etc/rc.conf, /etc/rc.firewall, and 
/etc/fstab that Phusion indicated.

Any ideas why my Virtual Machine cannot ping either the "HostOnly" IP or 
the FreeBSD's machine normal IP?  It also cannot ping my Linksys router, 
or any of my other machines.

Inside the VM I have the NIC defined as "Custom" and "/dev/vmnet1".  The 
  HostOnly and Bridged options did not work, as they seemed to be 
leaving off the "/dev/" in front of vmnet0 and vmnet1 (as I did too!).

Aside from no networking, Win 2000 Pro seems to be running pretty well 
inside VMWare 2.0.


More information about the freebsd-questions mailing list