cron can't find root or operator

chip chip at
Sat May 22 12:00:42 PDT 2004

Thanks for all the help. I like the changes so far. What about 
specifically mentioning in the Handbook chapter that when a user runs 
the command
crontab crontab
the user should do this in their own home directory. My problem was I 
ran it in the /etc directory, not knowing any better, probably becuase 
that bit wasn't mentioned in the Handbook, or if I recall correctly, 
even the FAQ. The Handbook text states
"Let us take a look at the /etc/crontab file (the system crontab):"
Followed by the section on the user crontab and the warning paragraph, 
but no mention of doing this in the user directory, not /etc.

So, now I am trying to run -
crontab crontab
in my non-root user directory, as the non-root user, and it fails with this-
"crontab: crontab: No such file or directory"
I tried -
crontab -u chip crontab -e 	(with and without the -e)
also and it failed with the same message. So I then su'd and tried again 
and got the same message again. The I tried -
/etc/crontab -u chip crontab 		(with and without the -e)
and get permission denied, as root.
I am running 5.1-Release, and a standard default install.

Bill Moran wrote:
> David Fleck wrote:
>> If you already have a file written in the proper format, you can load it
>> as your crontab by specifying 'crontab {filename}'. (That's what section
>> 6.6.1 in the handbook is trying to say.  Unfortunately, it is not at all
>> clear on this.)
> There was an outstanding PR on this ... I made a few additions, and I think
> the handbook will explain this much better now.  Sounds like a committer is
> going to get this into the tree within the next few days.

More information about the freebsd-questions mailing list