Problems with qmail and connecting to smtp daemon and problem with my virtual domain.

Mattias Björk mattias.bjork at
Fri May 21 15:44:29 PDT 2004

Hi, list(ners)

Problem nr 1.

I have read the following guide to install qmail:

I have not installed from source by my self, I found that all programs 
where avalible thru ports. I will make this as sort as possible, I set 
up vpopmail with domain "". The domain is "", 
fqdn is "" for the host. I didn't how ever install 
everything. I didn't install ezmlm-idx and auotrespond, but its not 
vital for the operation of the mail-server at this time.

I had this problem, that i couldn't send message to the FreeBSD 
mailinglists, but I solved it by adding my ISP outgoing smtpserver to 
/var/qmail/control/smtproutes. Perhaps it hade something to do with 
reversed DNS.

Here are my directory listing from /var/qmail/control/:

defaultdomain           plusdomain              smtproutes
locals                  rcpthosts               virtualdomains
locals.lock             rcpthosts.lock          virtualdomains.lock
me                      servercert.pem

In the file defaultdomain and plusdomain are the string entry 
"". In the me file there are the hostname of the mail server. 
And finaly in the "virtualdomains" file are the string: 

My problems is that I can connect to port 25. The problem is that 
nothing happens, look below:

thrawn/usr/home/thrawn/tmp% telnet 25
Connected to
Escape character is '^]'.
Connection closed by foreign host.

I don't even press a button before Im in the console again. I run the 
sockstat command on my server and I get the following output:

setiathome/var/qmail/control# sockstat  | grep :25
qmaild   tcpserve 66645    3 tcp4   *:25                  *:* 


And the output of "netstat -nl -f inet -p tcp | grep 25" does not show 
anything how ever.

How ever, in the first chapter of the guide. It says the following at 
"1.6 courier-imap Hack" :

"Because the SMTP after IMAP4(s)/POP3(s) of courier-imap does not work, 
here is a small wrapper. This "hack" tracks the IP of the authenticating 
user and allows for SMTP sending (i.e. a form of authenticated SMTP relay)."

Perhaps that have something to do with that it doesn't work.

Problem nr 2.

The other problem is that I have a user named "thrawn" that is a local 
user on the system.
The home directory of the user is "/usr/home/thrawn".
And the the Maildir diretory is "/usr/home/thrawn/Maildir". When I 
connect to my mail via imapd-ssl, It uses the local user Maildir.

But I have a domain for vpopmail at the following directory 

And there I also have a user named "thrawn" and with the same password 
as the local "thrawn" account. If I understand it correctly for some 
reason courier-imap doesn't use my virtual domain, but it does use the 
local user. Im sure that it might be me that I have done something wrong 
or the documentation is not completly correct.

Perhaps I should use another domain name and se if it works then, I 
haven't tested that yet. I think that it should work anyway, but I might 
  be wrong.

I hope that this information is of some use and I haven't forgotten to 
mutch information.

Thanks Mattias Björk

More information about the freebsd-questions mailing list