Filesystem/disk performance problems

Paul English penglish at
Tue May 11 14:42:51 PDT 2004

I have a filesystem which is showing some very odd problems on FreeBSD
4.4. The system has one 60GB IDE drive for the os and some user partitions and
one 800GB array of 120GB disks attached to a 3ware IDE-RAID controller.
The latter is all one big partition.

For most files and directories, copying/transferring them around is not a
problem. But for a couple of very specific directories, copying them seems
next to impossible. When I attempt to copy these, after a few minutes of
*extremely* slow copying (<1k/min), the system load shoots up and the
system becomes virtually unusable.

In particular, working with one directory which is 11GB. Some
subdirectories, even large ones copy fine from /usr1 (a partition on the
60GB disk) to /raid (the partition for the entire raid array).

I can even make a tar of one of the non-working directories to /usr1, copy
the tar file to /raid (with no problems), then when I try to untar it on
/raid I get the same problem - very very slow (<1k/min) and then the
system load shoots up to 10+ and the system becomes unusable.  In this
case the data is going from /raid -> /raid instead of from /usr1 -> /raid,
but it does not seem to help.

I've also tried using some other utilities than simply "cp" in an attempt
to "fool" the system - I've tried scp, and tar cf - . | (cd /raid;tar xf
-) as well.

There are no messages in dmesg or /var/log/messages that look at all
related, and there are no messages that are accruing (for example while
attempting a copy).


More information about the freebsd-questions mailing list