ps2 optical wheel mouse problems

Alex de Kruijff freebsd at
Sun Feb 29 17:15:15 PST 2004

On Sun, Feb 29, 2004 at 11:04:30AM -0700, Jerry M. Howell II wrote:
> On Sun, Feb 29, 2004 at 06:55:50PM +0100, Alex de Kruijff wrote:
> > On Sun, Feb 29, 2004 at 09:39:26AM -0700, Jerry M. Howell II wrote:
> > > Hello all.,
> > > 
> > >   I recently installed freeBSD 5.2 and have a problem. I have most
> > >   everything working corectly except the mouse. I set it to auto and it
> > >   detects the mouse but it jumps all over the screen. It's a prety
> > >   standard optical wheel mouse that seems to work fine under 4.8 and
> > >   under all distros of linux I've used so far. I've tried every
> > >   configuration I can think of under the sun. Does anyone have any
> > >   recomendations?
> > 
> > Hi,
> > 
> > There are two main ways of setting up the mouse. The first is to go only
> > with the X config and the second is to rely on the consile setup. If you
> > didn't use the second option, then please read the FAQ on the website.
> > Could you please tell use wich option you used? It would also be a handy
> > to have the configuration files or those parts there of that are
> > relevant.
> > 
> First I used /stand/sysinstall and selected the auto selecton. It
> detected the mouse but started jumping. After that I decided to select
> auto from the xf86config script, when that didn't work I tried sysmouse
> but got no beter response. One thing I did notice one thing. If I hook
> up a normal ps2 mouse and enable the mouse it works fine, even when I
> swap out the normal mouse for the optical but when I reboot if I have
> the optical mouse atached it goes back to jumping around. Realy weard.

I have a wireless optical mouse ( MX700 from logitech) and thats working
fine. Could you try and see if you have a working mouse in the console
by setting in /etc/rc.conf these lines:

moused_flags="-a .4"


Articles based on solutions that I use:

More information about the freebsd-questions mailing list