FreeBSD nat machine semi-crashing? with lots of connections going through it and a change of IP address

Markie mark.cullen at
Sat Feb 28 18:21:39 PST 2004

Hi all

I am having a few problems with a FreeBSD gateway machine, as you may have
guessed. A little bit of background info:

I was running 4.8-R-p<can't remember> for a long while, all running smooth.
Whilst it was up I had cvsupped to 4.8-R-p18 was it? I think... anyhow, my
brother tripped over the adsl line and it got unplugged so I took that
oppertunity to installworld and installkernel and reboot. This is where my
troubles seemed to have begun...

Everything seemed normal until out of the blue the box appeared to have
locked up on me and it was pretty close to a point where for whatever reason
I got disconnected. It was a rather old 133MHz and I had a 350MHz machine
laying around which I was going to swap over with it. I did that, just stuck
the two network cards and hard disk into that PC booted up and it worked
first go (I'm impressed :)) left it for a while, turned the modem off and
back on and it locked up again very shortly after soooo I updated to
4.9-R-p2 to see if that would fix it, nope!

Next up I tried swapping the outside ethernet card attached to the modem
with a nicer fxp card, it was using an old 3com etherlink III card before
that, but I had the same problem still! So i've come to believe it's got
nothing to do with the hardware at all now? Anyway, I kept messing about and
stuck a graphics card in and plugged a monitor in and noticed that just
before it locked up I got flooded with icmp redirect messages....
lots....and it then occured to me that all this time I had overnet running
on my windows machine which makes alot of connections, 30 to server things
and then 1 for each download source person I think? So I closed that and
repeated the tests and it didn't do it! As soon as I ran it again though,

I know it's a bit sad like, perhaps I shouldn't be bothered about it.....
but it's annoying me since I figured out what it is! Anyway, after fiddling
and making it 'crash' (it never panics, just seemed to lockup) I starting
hitting the keyboard ... mainly out of stress :) and hit the scroll lock key
and noticed the cursor disappeared as if it was going to let me scroll on
the console, pressed the up arrow or page up and it just went into a long
continous beep. The next time I tried ctrl + break and it said something
along the lines of 'no debugger in kernel'. So I went on to compile this
kernel debugger... although I am not sure how useful it's going to be. I
managed to force it to panic when it apparently freezes up and got a umm
backtrace? from the core dump too:

panic messages:
panic: from debugger

syncing disks...

Fatal trap 12: page fault while in kernel mode
fault virtual address   = 0x10
fault code              = supervisor read, page not present
instruction pointer     = 0x8:0xc02313e1
stack pointer           = 0x10:0xc02a275c
frame pointer           = 0x10:0xc02a27b4
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, def32 1, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = Idle
interrupt mask          = tty
panic: from debugger
Uptime: 12m1s

dumping to dev #ad/0x20001, offset 65664

kgdb) bt
#0  0xc015f5f2 in dumpsys ()
#1  0xc015f3bc in boot ()
#2  0xc015f809 in panic ()
#3  0xc011fa89 in db_panic ()
#4  0xc011fa27 in db_command ()
#5  0xc011faee in db_command_loop ()
#6  0xc0121cc7 in db_trap ()
#7  0xc024b312 in kdb_trap ()
#8  0xc025af4c in trap ()
#9  0xc024b561 in Debugger ()
#10 0xc02464a6 in scgetc ()
#11 0xc0242b65 in sckbdevent ()
#12 0xc023a217 in atkbd_intr ()
#13 0xc0267458 in atkbd_isa_intr ()
#14 0xc01c0b27 in ipfw_chk ()
#15 0xc01c3316 in ip_input ()
#16 0xc01c3997 in ipintr ()
#17 0xc024d679 in swi_net_next ()

I'm not to sure what else to say but I sure hope someone can help me out
here, please? :o) Any more info needed just ask!


More information about the freebsd-questions mailing list