MySQL Port... [not]missing functions?

Joe Lewis joe at
Thu Feb 26 22:09:53 PST 2004

Hey, all.  I have written an apache module, and it worked fine with 
MySQL 3.23 compiled from source but not in the 4.x ports (tried 4.1 and 
4.0).  I have found the problem when I shifted it to a new box.  The old 
one ran 5.1, and this new one runs 5.2.  I doubt the OS is the concern, 
but one can't be too careful.

The installed packages are :

mysql-client-4.0.16 Multithreaded SQL database (client)
mysql-server-4.0.16 Multithreaded SQL database (server)
apache-2.0.48_1     Version 2 of the extremely popular Apache http server
mod_php4-4.3.4_2,1  PHP Apache Module

Now, since I've used the port, all I get when trying to start apache 
with the recompiled module is :

Cannot load /usr/local/libexec/apache2/ into server: 
/usr/local/libexec/apache2/ Undefined symbol 

Can someone tell me what I am doing wrong?  I KNOW that function is 
supposed to be in the MySQL library, but it just isn't being found.  Is 
there some trick that was used in the port that is not part of the 
standard install for MySQL?


More information about the freebsd-questions mailing list