Robert Storey y2kbug at
Tue Feb 24 19:01:15 PST 2004

I've decided to install proftpd from ports since (it is said) to be more
robust than the FBSD ftpd daemon.

I went to /usr/ports/ftp/proftpd. The port downloaded, compiled, and
appeared to install correctly. I edited /etc/rc.conf to make sure that
the /usr/local/etc/rc.d/ would run at boot time. I checked
file proftpd.conf to make sure it was in standalone mode.

However, it does not start. If I manually run the command
"/usr/local/libexec/proftpd start", I receive this error message:

  error opening scoreboard: no such file or directory

According to the man page, there should be a file called
/var/run/run/proftpd/proftpd.scoreboard but I see that it does not exist
on my machine. I tried creating it with the "touch" command, but  that
doesn't really do anything useful. In fact, I know from running
Slackware that this should be a binary file, not an empty file, so I
didn't have much hope that this would solve anything.

I also tried starting Proftp from /etc/inetd.conf, but that was also
unsuccessful. Again, I received the same error about the missing

At this point, I'm stumped, so I hope that somebody who has succeeded in
getting Proftp working on FBSD has some advice.


More information about the freebsd-questions mailing list