Fail to start KDE

Stephen Liu satimis at
Sun Feb 22 19:49:04 PST 2004

Mike Jeays wrote:

>>Version 5.2
>>new installation
>>- snip -
>Create a file .xinitrc in the home directory, containing the single
>line 'startkde &' (without the quotes).  Then try startx again.
Hi Mike,

Tks for your advice.

Sorry I forgot to mention in my previous posting;

KDE could not start if editing /etc/ttys as;
ttyv8  "user/local/bin/xdm -nodaemon" xterm on secure

# startkde (on INIT 3/text mode)
Kpersonalizer: cannot connect to X server. 
(continue to run on screen)

I suspect whether it was caused by failure on login.  Because after 
booting, the 'Welcom to the XFree86 Project Inc' GUI login popup.  I can 
keyin either as 'root' or as 'username' but can't keyin password.  I 
just typed in password and hit <Enter> the GUI login screen popup again 
without mentioning anything.  The X window started with a small Xterm 
window appearing on the screen, mouse working but I could not type on 
it.  I tried many times without a solution.  If changing 'xdm' to 'kdm' 
on the abovementioned line 'ttyv8.....', GUI login failed to start. 

# startx  (on INIT 3)

started 3 'Xterm windows'

After starting 3 'Xterm windows' I can start KDE 3.1 from any one of the 
'Xterm window' with;

# startkde

It worked with KDE started.

3) On INIT 3/text mode I can login either as 'root' or as 'user' with 
correct password without problem

Kindly advise how to fix the problem.  TIA


More information about the freebsd-questions mailing list