endless "sysquery: no addrs found for root"

Mike Maltese mike at pcmedx.com
Thu Feb 19 21:05:27 PST 2004

> When I try to start named with this config, the log file shows
> Feb 19 22:16:50 jsrh named[177]: starting (/etc/namedb/named.conf).  named
8.3.7-REL Tue Feb 17 15:01:48 CST 2004
john at dexter.starfire.mn.org:/usr/obj/usr/src/usr.sbin/named
> Feb 19 22:16:50 jsrh named[178]: Ready to answer queries.
> but then I get an endless stream of
> Feb 19 22:16:58 jsrh named[178]: sysquery: no addrs found for root NS

I've experienced the exact same thing with 8.4.4 on 4.9-RELEASE-p2. It
actually filled up /var once. It was doing it randomly, now it seems to
contain itself to startup and only for about 20-30 seconds. Then it will
mysteriously stop and DNS works fine.

> for each one of the root name servers.  Just for grins, I downloaded the
> lastest named.root file, but that didn't help (of course).

I also tried the same thing, got the same result.

Just letting you know you're no the only one. =) The real question is
whether this a BIND problem or a FreeBSD problem.

More information about the freebsd-questions mailing list