solution for ad/ar geometry problem sought

Robert Eckardt Robert.Eckardt at
Mon Feb 16 14:34:00 PST 2004


has someone a solution for the following geometry problem with
IDE disks on a raid controller?

When activating the raid (RAID1) the system sees a different geometry
on ar1 than it saw on ad5 and thus finds no filesystems.

System is FBSD5.2R, EPoX 4GEA+, HPT372N, 2*77GB HDS + 2*114GB Maxtor.

I install the system on one of the maxtors on device /dev/ad5.
(ad4+ad6=ar0 carries the old 5.0 system, which accesses the raid
 via HighPoint's driver as da1
 da1 at hpt37x20 bus 0 target 0 lun 0
 da1: <HPT Inc. HPT37x2   RAID 1 1.05> Fixed Direct Access SCSI-2 device
 da1: 78533MB (160836480 512 byte sectors: 255H 63S/T 10011C)
 da2 at hpt37x20 bus 0 target 1 lun 0
 da2: <Maxtor 6 Y120P0 YAR4> Fixed Direct Access SCSI-2 device
 da2: 117246MB (240121728 512 byte sectors: 255H 63S/T 14946C)
 da3 at hpt37x20 bus 0 target 2 lun 0
 da3: <Maxtor 6 Y120P0 YAR4> Fixed Direct Access SCSI-2 device
 da3: 117246MB (240121728 512 byte sectors: 255H 63S/T 14946C)
Sysinstall complains about the geometry 238216/16/63 and claims to
use 14946/255/62 instead.
I tried the wizard mode, only to learn that setting the geometry to
any value (e.g. to 29777/128/63 which is the same size as initially
without rounding errors) it gets reset to 238216/16/63 when I write
the new geometry to disk. So I installed anyway. I don't argue with
my computer.
On reboot after installation the disk is recognized as 238216/16/63
and everything works fine.

Then I create the mirror using "atacontrol RAID1 ad5 ad7" and
after checking the raid status for READY and adjusting fstab I reboot.
The kernel is loaded and ar1 has 14946/255/62 while ad5 still has
238216/16/63. Thus, the kernel cannot find the superblock of the
root-FS and stops. I can continue by specifying "ufs:ad5s1a" as a new
root but then fstab only contains references to ar1.

Now, why is it good to access the disk with and without raid?
It happened to me that ad6 broke.
After replacing ad6 I started the resync ... until 6% were done.
Then the system ran on a uncorrectable read error on ad4 (the original)
No data was touched but resyncing didn't work.
So I broke the mirror, used dump|restore on the "raid-less" disks and
replaced ad4 too.
Finally the resync worked.
HighPoint's driver presented the disks and raid arrays to me always
with the same geometry.

So, where can I tweak the system to see the same geometries on ad5/ad7
and on ar1 ???

Any help appreciated!

Thanks in advance,


More information about the freebsd-questions mailing list