4.x disk slice missing in 5.2.1-RC

Bartosz Fabianowski freebsd at chillt.de
Fri Feb 13 05:01:12 PST 2004

Hi all!

On one of my hard disks, I have two slices. The first, /dev/ad4s1, is 
fromatted FAT32 and contains a Windows installation. The second, 
/dev/ad4s2, contains a FreeBSD 4-STABLE installation. The FreeBSD slice, 
of course, is further split into the usual partitions (/dev/ad4s2a and 
so on). Those partitions are all formatted UFS1.

When I boot into this 4-STABLE installation, all slices and partitions 
are found and the system runs perfectly. However, when I boot into 
5.2.1-RC, which I have installed onto another hard drive (/dev/ad6s1), 
the /dev/ad4s2 partition is missing.

At boot time, the entries /dev/ad4 and /dev/ad4s1 are created - so the 
FAT32 partition is found. But the entry for /dev/ad4s2 is missing. I 
tried looking for the partition using fdisk and it is found as the 
second partition, containing a *BSD system. I then tried to check the 
disk labels, but disklabel complained that /dev/ad4s2 does not exist.

Mounting any partition such as /dev/ad4s2a doesn't work either, as the 
entries are not auto-created by devfs since their parent /dev/ad4s2 does 
not exist. I tried to manually create this device entry, but mknod 
wouldn't let me.

So, I am out of ideas. How can fdisk see the partition, 4-STABLE boot 
just fine from it, but devfs simply ignore it? Any help would be greatly 

- Bartosz Fabianowski

More information about the freebsd-questions mailing list