anubis anubis357 at
Thu Feb 12 01:20:06 PST 2004

On Wed, 11 Feb 2004 10:00 pm, Edd Barrett wrote:
> Hi there. I think i may have discovered a bug in free bsd 5.2-RELEASE, it
> may be in earlier versions too, but I have not tried it (maybe someone
> running 4.x could try it)
> I have made an fstab entry and nsmbrc file for a smb share. vfs.usermount
> is set to 1.
> A normal user (me in this case (edd)) can mount a cdrom drive (on a dir
> owned by him):
> mount /home/edd/cdrom
> umount /home/edd/cdrom
> this returns no errors and proves that vfs.usermount is working for cd9660
> fs.
> mount /home/edd/rhome
> works fine... but
> umount /home/edd/rhome
> does NOT work. (permission denied) Is this a bug or am I being dumb?
> Thanks!
Let me ask the obvious.  Are you seeing anything in the logs?  You dont happen 
to have /home/edd/home as your current directory when you try and dismount?
Have you tried umount -v or umount -f?

I had a similar problem but i cant quite recall how i solved it.  Ill look at 
that machine in the next few days and see.

More information about the freebsd-questions mailing list