FreeBSD 4.9, Apache 2.0.47 and PHP 4.3.3

Mike Bowie mike at
Tue Feb 10 17:33:37 PST 2004


I should probably be asking this in an Apache or PHP group, but given that the =
source of the issue seems to be so elusive, I can't point the finger at either =
just yet so I'm hoping someone here can point me in the right direction.

I have a fresh FreeBSD 4.9 server running at a co-location facility.  I've =
twiddled the kernel a little for firewalling and removed all of the devices not =
in use.

Once the install was complete, I cvsup'd the ports tree to cvs release, in =
order to have the more recent builds available and installed PostgreSQL, Apache =
and PHP4 as I usually do.  I then went to work preparing the sites to be =
transferred to the new environment.

The problem is, every now and then, (generally after Apache has been running =
for about an hour, but sometime after only a few minutes,) Apache stops parsing =
the files as PHP and starts serving them unparsed as application/x-httpd-php, =
which obviously doesn't go over well.

When it started to happen, I first blamed my rather sleek httpd.conf, which I =
use on about four other servers as it is... without fault.  So I setup my =
virtual host entries etc in the default httpd.conf and went back to porting the =

It happened  again... so I blamed the PHP module, so I rebuilt it again with =
only the default options, minus mysql and plus postgresql.  Same result. =20
So I reverted back to the original ports tree which shipped with 4.9 and =
rebuilt PHP again.  Same result.
I then rebuilt Apache from the original 4.9 ports tree and PHP again to =
match... same result.

It's almost like PHP is core dumping somewhere... without warning or notice.  I =
can't seem to get anything special to come out in the logs, even when I run =
"httpd -e debug -X" it happens and doesn't tell me anything.

The most frustrating thing is the lack of knowing where to begin.  Without =
anything returning an error, I'm stumped.  Any suggestions are welcomed!

Thanks in advance,


ps... I'd attach my whole httpd.conf and php.ini, but the problem presents =
itself even when I use the stock versions from the ports installations.

=3D=3D=3D=3D=3D begin virtualhost example =3D=3D=3D=3D=3D

<VirtualHost _default_:80>
    # Server values and flags
    DocumentRoot "/usr/local/www/html"        =20
    # Parse .html files as PHP scripts
    AddType application/x-httpd-php .html
    # Compatibility flags while porting
    php_flag asp_tags on
    php_admin_flag register_globals on
    # Directory level controls
    <Directory "/usr/local/www/html">
        Order allow,deny
        Allow from all

=3D=3D=3D=3D=3D end virtualhost example =3D=3D=3D=3D=3D

More information about the freebsd-questions mailing list