problems reading compactflash with USB

Jim Blomo jblomo at
Mon Feb 9 01:28:12 PST 2004

Hi, thanks for listening.

I have USB card reader that has worked in both linux and windows.  It is
being recognized during boot time on my 4.9-RELEASE machine:

ohci1: <AcerLabs M5237 (Aladdin-V) USB controller> mem
0xdff5c000-0xdff5cfff irq
 10 at device 20.0 on pci0
usb1: OHCI version 1.0, legacy support
usb1: <AcerLabs M5237 (Aladdin-V) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: AcerLabs OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
umass0: CYPRESS SM-CF 0.78 CYPRESS SM-CF 0.78, rev 1.10/0.78, addr 3

The reader has a formated card in it (with pictures from a powershot
a70).  However, further on down in the boot process I run into errors:

da0 at umass-sim0 bus 0 target 0 lun 0
da0: <CYPRESS SM-CF 0.78 > Removable Direct Access SCSI-0 device 
da0: 650KB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present

When I try to mount the device, 

# mount -t msdos /dev/da1s1 /mnt/
(da0:umass-sim0:0:0:0): READ CAPACITY. CDB: 25 0 0 0 0 0 0 0 0 0 
(da0:umass-sim0:0:0:0): NOT READY asc:3a,0
(da0:umass-sim0:0:0:0): Medium not present
msdos: /dev/da1s1: Device not configured

I get this exact same error trying to do anything with the disk,
including fdisk, newfs, newfs_msdos, or trying to mount any other
partition.  I've tried to use camcontrol to scan for new devices without
any luck:

# camcontrol inquiry 0:0
camcontrol: cam_open_btl: no passthrough device found at 0:0:0

I can't really get any infromation from the device to see if it needs to
have some quirk rules added.

# usbdevs -v
Controller /dev/usb0:
addr 1: self powered, config 1, OHCI root hub(0x0000), AcerLabs(0x0000),
rev 1.00
 port 1 powered
 port 2 powered

I'm using # uname -a
FreeBSD Blackfoot 4.9-RELEASE FreeBSD 4.9-RELEASE #0: Mon
Oct 27 17:51:09 GMT 2003
root at  i386

I'm not sure where to go from here, and any advice would be greatly
appreciated.  Please CC me on replies, as I'm not subscribed to this

Jim Blomo

More information about the freebsd-questions mailing list