freeBSD 4.9 stable hang on start_init: trying /sbin/init

treeml treeml at
Wed Feb 4 04:30:34 PST 2004

Sergey, thanks for the answers.  I did a

# dd if=/dev/ad1s1a of=/dev/null bs=128k
2048+0 records in
2048+0 records out
268435456 bytes transferred in 7.044954 secs (38103223 bytes/sec)

So it looks like my / partition in intact.  I can mount and see all the file
in that root partition as well as other ones.  Just can get it to boot.  I
have tried resting my BIOs, no luck.
I have tried to perform an upgrade from the 4.9 CD, but every time I get the
point where it is looking for files on CD, it fails.   I may try again from
an FTP site. But I got the feeling reinstalling it will not fix the problem.


-----Original Message-----
From: Sergey 'DoubleF' Zaharchenko [mailto:doublef at]
Sent: Wednesday, February 04, 2004 6:44 AM
To: treeml
Subject: Re: freeBSD 4.9 stable hang on start_init: trying /sbin/init

On Wed, 4 Feb 2004 05:41:14 -0500
"treeml" <treeml at> probably wrote:

> After a power failure, my freebsd 4.9 stable is giving out the UDMA ICRC
> error. (see my first email below), but after a few boot, and change of a
> cable, it is no longer giving out that error.
> However, it still hangs at boot at
> >Mounting root from ufs:/dev/ads1a
> If I boot with "boot -v" option.  It will stop at
> >Start_init: trying /sbin/init

My bet is that the data in /sbin/init is broken. Do an md5 /sbin/init
and send it to the list. Be sure to supply the date of your sources
(as you're using STABLE, not 4.9-RELEASE) (or the output of ident
/sbin/init). If nobody confirms the same checksum, then perhaps I'm

> This happens with my custom kernel and the default kernel.  I also can't
> boot into single user mode using "boot -s"
> It is worth mentioning that I was able to boot the box from a FreeBSD 5.1
> rescue CD, and remount all the partitions. I even used fsck and check all
> the partitions to make sure they are clean.  But still can't boot from it.

fsck will not necessarily notify you if there are hardware read errors
somewhere on the drive. It just makes sure the filesystem areas are
consistent and readable, not the data.

If you use dd to read the whole disk, say

# dd if=/dev/ad1s1a of=/dev/null bs=128k

and it completes successfully, then it might be not a hardware fault,
but something else.

I'm sorry to say, but recently I had a power failure and it damaged my
80G Seagate (and FreeBSD gives pretty much the same errors when
attempting to access the damages sectors).

> I have search the Internet, and it looks like quite a few people had the
> same problem during installation, but I didn't find any suitable

People will accept your ideas much more readily if you tell them that
Benjamin Franklin said it first.

More information about the freebsd-questions mailing list