ipmon logging problem

andy at neu.net andy at neu.net
Tue Apr 27 13:11:40 PDT 2004

I am also having a problem getting logging to work (as described below).
I tried to start it manually with:

ipmon -P -D -oi /var/log/ipflog

and I get a message saying "unknown log option i".

I read http://www.freebsd.org/cgi/query-pr.cgi?pr=misc%2F56715, and it
says "start ipmon after initializing ipfilter".  So, I changed the order
of the entries in rc.conf and now the ipmon statements are above the
ipfilter statements, rebooted but still nothing in the log.  Does the
order of the statements in rc.conf mean anything?  How do you get ipmon to
start after ipfilter?


John Murphy wrote:
> Thanks both for the suggestions.  I tried:
> ipmon_flags="-Dsn" and ipmon_flags="-oi /var/log/ipflog"
> to no avail.  I even read man ipmon!
> As far as I can tell ipmon is not starting via rc.conf.
> If I start it manually with:
> ipmon -P -D -oi /var/log/ipflog it works (although I don't
> see a PID in /var/run even if I leave out the -D).

More information about the freebsd-questions mailing list