Problem starting jail

Harald Schmalzbauer h at
Sat Apr 24 14:41:06 PDT 2004

Am Samstag, 24. April 2004 06:18 schrieb Gerald Holguin:
> Hello,
> I am running FreeBSD 4.9.
> I am new to Unix (great learning).
> I have setup the jail according to the man page with no errors and upon
> completion while trying to start the jail I get this error:
> bsdbox# jail -u root /home/jail/ ecj /bin/sh
> jail: execv: /bin/sh: No such file or directory
> I have also tried to start the box with the following invocation:
> bsdbox# jail /home/jail/ ecj /bin/sh and I get
> the same error:
> "jail: execv: /bin/sh: No such file or directory"
> The /bin/sh file does in fact exist under the host environment.

You need /bin/sh in the jail environment! It's the first process which gets 
started in the jail.


> Anyone have some advice?
> Gerald
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at"

Please never add my reply address to CC nor to the recipient list!
If you make "answers to all" please remove my address!!!!!!!!!!!!!
I'll complain if I see my reply address on any mailinglist!!!!!!!!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: signature
Url :

More information about the freebsd-questions mailing list