BIND 9.2.3 error in chroot

Langver, Nathan Nathan.Langver at
Tue Apr 20 05:53:51 PDT 2004


I got the same error's as you. But I fixed it when I used the mknod random c 249, 0 in /etc/namedb/dev/ 

Which is equal as in /dev/random

This problem also was in earlier versions, but then you had to do 
mknod random c 2 3 Which in turn was equal to the /dev/random from version 4.9 and 5.0 

Hope this helps 

Greetings Nathan 

-----Original Message-----
From: dave [mailto:dmehler26 at] 
Sent: dinsdag 20 april 2004 14:29
To: Langver, Nathan
Subject: Re: BIND 9.2.3 error in chroot

    Which error are you getting when you try to run bind chrooted? I had it
working chrooted fine under 5.1, but when i installed 5.2.1 i am now getting
some strange bootup messages:
IP Filter: v3.4.31 initialized.  Default = block all, Logging = enabled
Starting ipmon.
Enabling ipfilter.
ioctl(SIOCIPFL6): Invalid argument
Installing NAT rules.
0 entries flushed from NAT table
0 entries flushed from NAT list
Starting named.
Starting ntpdate.
Apr 16 21:58:12 guardian named[329]: errno2result.c:109: unexpected error:
Apr 16 21:58:12 guardian named[329]: unable to convert errno to isc_result:
6: D
evice not configured
Generating host.conf.
Clearing /tmp.
ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib
a.out ldconfig path: /usr/lib/aout /usr/lib/compat/aout
Recovering vi editor sessions:.
Have you ever seen any of these particularly the bind startup messages?

More information about the freebsd-questions mailing list