Microsoft wireless mouse problem

10,000 Screaming Monkeys bsd at
Sat Apr 17 11:26:55 PDT 2004

On 04/17, Mark Ovens rearranged the electrons to read:
> Ah, now that _does_ WFM, and that fact makes me suspect that the
> problem lies with the USB driver rather than the mouse driver.
> What are your mouse settings in rc.conf and XFree86config?

At the moment, all I have in /etc/rc.conf is:


That seems to detect the mouse properly and starts moused with the
correct port.

/etc/X11/XF86Config is:

	Section "InputDevice"
		Identifier  "Mouse0"
		Driver      "mouse"
		Option      "Protocol" "auto"
		Option      "Device" "/dev/sysmouse"

I've also tried killing moused and pointing the Device to /dev/ums[01],
but that didn't seem to make a difference.

> I really think it would be worth getting this problem solved as MS 
> cordless mice are very popular. 

They're not only popular, they're almost the only thing you can buy
anymore. I wanted a corded keyboard and mouse for work, but the only
models manufacturers put out with cords anymore (for keyboards, anyhow),
if they sell one at all (Are you listening, Logitech? You bastards...)
feel like crap to type on. But this isn't the place for that rant.

Also, to address Lucas Holt's comment, the keyboard & mouse combo I'm
trying to get working at work is the infrared model. I have the
Bluetooth model keyboard/mouse at home, but it's not connected to a BSD
box. I'm still puzzled why the wireless keyboard would work fine, but
the wireless mouse, which uses the same receiver, doesn't.


More information about the freebsd-questions mailing list