4.9R - BTX HALTED problem - my solution

Keith Baldwin keith at southo.net
Fri Apr 16 13:56:16 PDT 2004

After reading an agonizing thread in freebsd-hackers from back in 2000 with
no solution in layman's terms, this is how I got this to work.

My system:
Celeron 1.7Ghz
MSI MS6526 v2  mobo (Intel arch, apparently this and/or the bios is the

The problem: 
After doing a new cd install using the sysinstall menu's as I normally do
this machine failed to boot. All I had to go on was a bunch of technical
"garbage" and the message BTX HALTED.

The solution:

Boot with the install cd
Select Standard Install
In fdisk, as suggested in the freebsd-hackers thread, I tried altering the
disk geometry to what my BIOS "sees". That has never worked for me.
Nonetheless, I did try it. Fdisk just complains and reverts back to what
fdisk "sees".
Create one Slice or select "A"
Select "F" for dd mode, select yes when prompted.
Make the freebsd slice bootable with "S"
Quit fdisk with "Q"
At the Disklabel part of the install select "A"
I didn't like the setup so I deleted all and recreated my scheme.
Quit disklabel with "Q"
When prompted for the boot manager I chose Standard (no boot manager)
The install continued and viola, the box booted normally.

Hopes this helps.


More information about the freebsd-questions mailing list