jumping mouse in X

John Mills johnmills at speakeasy.net
Wed Apr 14 06:55:58 PDT 2004

Tsu-Fan Cheng -

On Tue, 13 Apr 2004 tscheng at ic.sunysb.edu wrote:

> ...
> something I found in XFree86log file:
> (**) Option "Protocol" "auto"
> (**) Mouse0: Protocol: "auto"
> (**) Option "CorePointer"
> (**) Mouse0: Core Pointer
> (**) Option "Device" "/dev/psm0"
 Do you know this is correct?

> (**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
> (==) Mouse0: Buttons: 3
> (II) Keyboard "Keyboard0" handled by legacy driver
> (II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
> (II) Mouse0: SetupAuto: hw.iftype is 3, hw.model is 0
> (II) Mouse0: SetupAuto: protocol is SysMouse
> (WW) fcntl(6, O_ASYNC): Inappropriate ioctl for device
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> is this causing the trouble?
> -----------------------------------------------
> Hi freebsd-er, I recently upgraded my m/board and finally get x-window to
> work again but my mouse is all very jumpy, I seem to lose control over it
> and very hard to make it stay on one position.

This has happened to me when I had chosen the wrong mouse protocol ('mm', 
'logitech', etc.) in 'XF86Config'

You may want to try reconfiguring that part of X11. If it acts no 
differently, perhaps you have the wrong interface (note above). If it is 
different, but not correct, try another protocol.

DISCLAIMER - my experience here is Linux, but the problem was in the XF86 
configuration, which should be nearly the same..

 I have been trying to see
> what people have to say on the internet. Something I came across is that
> the driver for vedio card might affect it. My cedio chip is ProSavageDDR
> K4M266, I can't run x-win when using original FBSD driver, but after
> installing a 3-rd party driver, I was able to get it up, and everything
> looked the way I wanted it! But just this mouse, it went crazy. It's a
> 2-button ps/2 mouse, I tried "auto" or "ps/2" protocol in X config,
> nothing changed, I tried to put some moused related stuff in /etc/rc.conf,
> then I get a nice working mouse in my console, but my x-win won't start up
> because the mouse device is "busy". Any help! thanks!

That sounds like the wrong 'device' selection, but I don't have any way to 

 - John Mills
   john.m.mills at alum.mit.edu

More information about the freebsd-questions mailing list