SOLVED - 5.2.1-RELEASE boot problem

10,000 Screaming Monkeys bsd at
Mon Apr 12 17:21:49 PDT 2004

Nobody has been able to help me here or elsewhere, but I did discover
one strange thing that seems to have taken care of things.

The way I usually build my systems, since they're strictly FreeBSD
machines, is to "dangerously dedicate" the drive. When the system was
installed that way, regardless of what I did in /boot.config, regardless
of which IDE channel I had the drive connected to, and regardless of
BIOS settings tweaked to hell and back, it refused to boot from the IDE
drive and the boot loader would default to 22:fd(22,a)/kernel.

On a lark, I reinstalled the system using a "true" partition and the
FreeBSD bootmgr. When I rebooted the system after the install, it
prompted me for the partition to boot (F1 for FreeBSD) and booted
successfully without any trickery.

When I installed the system yet another time using a "true" partition
and chose the "standard" option (for just a standard MBR, rather than a
boot manager or "none"), the system booted completely normally without
any intervention on my part at all.

So, while I have no explanation for why it acts differently depending on
whether or not the drive is DD'd or given a "valid" partition, that's
what fixed the problem for me. I thought I would make a follow-up post
just in case this ever happens to anybody else and they need some place
to start.

- Jamie

On 04/09, 10,000 Screaming Monkeys rearranged the electrons to read:
> I know I'm going to regret asking this, because it's undoubtedly
> something simple that I'm missing, but I can't for the life of me make
> this work.
> A little background: I have FreeBSD 5.2.1-RELEASE installed on an ATA133
> drive, which is connected to a Soyo SY-P4S Dragon Ultra motherboard. The
> motherboard has 4 onboard IDE ports -- two regular (slower) IDE ports
> (labeled 1 & 2 on the board), controlled by the BIOS; and two faster
> "RAID" ports (3 & 4), controlled by an onboard Highpoint HPT370/372
> controller.
> When installing from CD, everything works as expected with no errors,
> regardless of which IDE channel/port I have the hard drive connected to.
> And, just to note, when I have it connected to IDE port 3 (an
> ATA133-capable port), FreeBSD addressed the drive as ad4 after booting.
> When attempting to boot after the install, however, the boot loader is
> apparently defaulting to a floppy drive, as this is all I get:
> 	Verifying DMI Pool Data ............
> 	error 1 lba 0
> 	error 1 lba 0
> 	No /boot/loader
> 	FreeBSD/i386 boot  
> 	Default: 22:fd(22,a)/kernel
> 	boot:
> If I type "0:ad(0,a)/boot/loader" at the boot: prompt, though, it
> actually runs the loader and presents me with the ASCII daemon and the
> boot menu.
> I've tried putting that "0:ad" statement in /boot.config, but it didn't
> seem to have any effect on the boot process (i.e., it still defaulted to
> 22:fd and gave me the same errors).
> Can anybody tell me what I might have missed, or what I might be doing
> wrong? My head is getting a little sore from beating it on random hard,
> flat surfaces.
> TIA,
> Jamie

More information about the freebsd-questions mailing list