Portupgrade problem

Andreas Davour ante at update.uu.se
Fri Apr 9 11:55:26 PDT 2004


I just decided to take a deep breath and cvsup some fresh ports. Now,
having done that I have run 'portupgrade -ar' and constantly found it to
stop some problems.

Some ports have failed and been flagged as "configure error" or "install
error". Then I have tried to do a manual install of those ports and found
that a "make deinstall; make reinstall" have worked, just like the port
instructed me to do when it failed. I found it strange that portupgrade
didn't do that for me.

Having done that I restarted portupgrade and it would proceed a bit before
stumbling to a halt again.

Now I have reached the end of what I can fix manually, though. For some
reason portupgrade stubbornly complains that:

"** Listing the failed packages (*:skipped / !:failed)
        ! accessibility/atk (atk-1.4.1_1)       (port directory error)"

And it is correct in that there *is* no accessibility/atk port in my new
cvsup'ed ports tree. But why is it then telling me it needs it!?

Can I get the atk ports from somewhere? Is it really needed? Why has it
dissapeared and why is it still mentioned as a dependency then?

If anyone can shed some light on those matters, then I'm all ears. I can't
get a new version of Firefox to compile without atk so I'm very interested
in getting this to work.

I have run 'pkgdb -F' and tried to remove the dependecy, but have not
succeeded. I'm not even sure it would be wise to do it...



=================== Emacs =====================
			mail: ante at update.uu.se
		  	or try: Koraq at yahoo.com
groove out at: http://www.update.uu.se/~ante/
====== The choice of a GNU generation! ========

More information about the freebsd-questions mailing list