Postfix - Sasl - mysql

Drew Tomlinson drew at
Tue Apr 6 21:31:15 PDT 2004

Brent Wiese told a big fish story including the following on 04/06/2004 
5:40 PM:

>I (tried) following the instructions at:
>I have postfix virtual users working in MySQL. I have courier imap/pop3
>working w/ virtual users. I wanted to add SMTP auth.
>I added the cyrus-sasl2 port (also chose support for it in postfix port)
>No go.
>I added the following lines to /usr/local/lib/sasl2/smtpd.conf (found this
>in another faq/tutorial, so it may be incorrect)
>sasl_pwcheck_method: auxprop
>sasl_auxprop_plugin: mysql login plain crammd6 digestmd5
>mysql_user: postfix-user
>mysql_passwd: thepassword
>mysql_database: postfix
>mysql_statement: SELECT password FROM mailbox WHERE username = '%u'
>mysql_verbose: yes
>(I also tried "sasl_" in front of all the lines).
>When I try to use SMTP Auth from Outlook Express, I get this in the logs:
>Apr  6 20:35:01 server01 postfix/smtpd[22279]: warning: SASL authentication
>failure: no user in db
>Apr  6 20:35:01 server01 postfix/smtpd[22279]: warning: SASL authentication
>failure: no secret in database
>Apr  6 20:35:01 server01 postfix/smtpd[22279]: warning:
>[]: SASL NTLM authentication failed
>I'm using cyrus-sasl-2.1.18 and postfix 2.0.19.
>I also tried compiling w/ the patch listed in that tutorial link above, but
>it breaks. I read somewhere that mysql stuff changed in cyrus-sasl-2.1.17.
>Any help? I think I'm really close... I'm just so frustrated at this point,
>I'm probably no longer thinking clearly.
I wasn't using mysql but had similar problems setting up SASL with 
Postfix.  After lots of searching, I finally found the answer and posted 
it to the list.  You can find my post here:

Maybe this will help you as my errors were similar.

Good Luck,


More information about the freebsd-questions mailing list