Problem upgrading /lang/librep (librep-0.16.2_2)

Bob Perry rperry4 at
Thu Nov 27 12:37:02 PST 2003

Joe Marcus Clarke wrote:

>On Thu, 2003-11-27 at 14:13, Bob Perry wrote:
>>Happy Thanksgivings,
>>Was upgrading my ports and ran into the following error message :
>>** The following packages were not installed or upgraded (*:skipped / 
>>        ! lang/librep (librep-0.16.2_2) (new compiler error)
>>        * x11-toolkits/rep-gtk (rep-gtk-gnome-0.15_1)
>>Later tried to install via ports process and rec'd the following output:
>>||===>  Building for librep-0.16.2_3 for dir in intl src lisp man; do \
>>  [ -d $dir ] && ( cd $dir && gmake all ) || exit 1; \
>>done gmake[1]: Entering directory 
>>`/usr/ports/lang/librep/work/librep-0.16.2/ intl'
>>gmake[1]: Nothing to be done for `all'.
>>gmake[1]: Leaving directory `/usr/ports/lang/librep/work/librep-0.16.2/i 
>>gmake[1]: Entering directory `/usr/ports/lang/librep/work/librep-0.16.2/ 
>>/bin/sh ../libtool --mode=link cc -export-dynamic -DHAVE_CONFIG_H -I. -I 
>>../src -I.. -I/usr/local/include -O -pipe  -o rep \
>>  rep.o  -L/usr/local/lib -lxpg4 -lintl -pthread -lcrypt 
>>-lgmp  -lm
>>cc -DHAVE_CONFIG_H -I. -I../src -I.. -I/usr/local/include -O -pipe -o .l 
>>ibs/rep rep.o -pthread -Wl,--export-dynamic  ./.libs/ -L/usr/lo 
>>cal/lib -lxpg4 -lintl -lcrypt -lgmp -lm -Wl,--rpath -Wl,/usr/X11R6/lib
>>./.libs/ warning: tmpnam() possibly used unsafely; consider us 
>>ing mkstemp()
>>./.libs/ undefined reference to `mpq_set_d'
>>gmake[1]: *** [rep] Error 1
>>gmake[1]: Leaving directory `/usr/ports/lang/librep/work/librep-0.16.2/s rc'
>>gmake: *** [all] Error 1
>>Any advice?  Don't remember seeing anything in the mailing list re this 

Thanks for such a a quick response.

>>I changed the librep dependencies last night, but I did a full test of
>>librep, rep-gtk2, and sawfish2 on -CURRENT before doing so.  What
>>version of FreeBSD is this?
FreeBSD 4.8-RELEASE-p13 0# upgraded from -STABLE.

>  What version of the libgmp4 port do you
>have installed?

Ran :
su-2.05b# make search key=libgmp4
Port:   libgmp-4.1.2_2
Path:   /usr/ports/math/libgmp4

Followed by:
su-2.05b# pkg_info -v libgmp-4.1.2_2
pkg_info: can't find package 'libgmp-4.1.2_2' installed or in a file!

>  The only time I saw this error, was when I original did
>the port, and it linked against
>Hmm...I bet this machine was upgraded from -STABLE, and you still have a
>/usr/lib/ link.  If you do, remove that file/symlink, and
>librep should build.
Removed both the link /usr/lib/ -> and the file 
and tried to build librep.  Here's the putput:

gmake[1]: Entering directory 
gmake[1]: Nothing to be done for `all'.
gmake[1]: Leaving directory `/usr/ports/lang/librep/work/librep-0.16.2/intl'
gmake[1]: Entering directory `/usr/ports/lang/librep/work/librep-0.16.2/src'
/bin/sh ../libtool --mode=link cc -export-dynamic -DHAVE_CONFIG_H -I. 
-I../src -I.. -I/usr/local/include -O -pipe  -o rep \
  rep.o  -L/usr/local/lib -lxpg4 -lintl -pthread -lcrypt -lgmp -lm
cc -DHAVE_CONFIG_H -I. -I../src -I.. -I/usr/local/include -O -pipe -o 
.libs/rep rep.o -pthread -Wl,--export-dynamic  ./.libs/ 
-L/usr/local/lib -lxpg4 -lintl -lcrypt -lgmp -lm -Wl,--rpath 
./.libs/ warning: tmpnam() possibly used unsafely; consider 
using mkstemp()
/usr/libexec/elf/ld: warning:, needed by ./.libs/, 
not found (try using -rpath or -rpath-link)
./.libs/ undefined reference to `mpq_set_d'
gmake[1]: *** [rep] Error 1
gmake[1]: Leaving directory `/usr/ports/lang/librep/work/librep-0.16.2/src'
gmake: *** [all] Error 1
*** Error code 2
Stop in /usr/ports/lang/librep.

Looks like librep is looking for  Reinstall?


FreeBSD 4.8-RELEASE-p13 0#

More information about the freebsd-questions mailing list