Jerry McAllister jerrymc at clunix.cl.msu.edu
Mon Nov 24 16:01:40 PST 2003

> Hi Jerry,
> Jerry McAllister wrote:
> > 
> > NOTE:   If you run disklabel and do not use the "-r" switch, then
> > what you are seeing is the socalled 'in-cure' version of the disklabel
> > and if no FreeBSD label has been written on the disk, the system will
> > make up some default stuff.   So, just seing # /dev/ad6 
> > and type: , etc plus the line for c: followed by those messages
> > saying cannot find label is a strong indication that nothing is there.
> > Has fdisk and disklabel (with a write switch) ever been done on this disk?
> > 
> I had this disk working in a FreeBSD 4.7 machine. When I installed 
> FreeBSD i created one partition on the disk and it worked without error.
> This was also strange:
> When I moved to my new home I took the disk out of the 4.7 machine for 
> transport. When I put it back and booted 4.7 there came the same errors 
> (BAD SUPER BLOCK ...). I then put the drive into a system running 
> Windows 2000 (don't know why I did this) and just startet it. 
> Immediately after that I shut down Win2000 and moved the disk back to 
> the 4.7 machine - booted it - and the disk worked again without error.
> I have no idea what happend there - I just was happy that all data was 
> still there.

Sounds like you made a visit to 'The Twilight Zone'.


> Regardz,
> Robert

More information about the freebsd-questions mailing list