Robert Neumann shritis at gmx.de
Sun Nov 23 22:55:29 PST 2003

Toomas Aas wrote:

> Hello!
>>Date:          Fri, 21 Nov 2003 10:53:06 +0100
>>From:          Robert Neumann <shritis at gmx.de>
>>this is the problem:
>>I had a machine running FreeBSD 4.7-Stable. There I added a 80GB 
>>harddisk. This harddrive I wanted to install on my other machine running 
>>FreeBSD 4.9-Release. This disk is ad6 so I added
>>	/dev/ad6	/storage	ufs	rw	2	2
>>to fstab and rebooted.
> Did I understand the situation right - the drive worked in 4.7 machine 
> but the problem occurred when you moved it to the 4.9 machine?
That's right.

> The above fstab entry doesn't look quite correct to me. The filesystem 
> that you mount should usually be contained in a partition (e.g. 
> /dev/ad6s1e) not on entire disk (/dev/ad6).
> If the drive worked in the 4.7 machine, what was the fstab entry there?
I cant recall the fstab entry but the drive was as Master on the 
secondary IDE channel and had only one partition using all diskspace.

In the 4.9 machine the drive is on a DMA-66-Controller. Under Win2000 
this is listet as a SCSI-Device. I don't know whether this can be the 
problem - I will try to put it again on the IDE-Channel.

> What is the output of 'disklabel ad6'?
# /dev/ad6:
type: unknown
disk: amnesiac
label: fictitious
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 255
sectors/cylinder: 16065
cylinders: 9964
sectors/unit: 160086528
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0		#milliseconds
track-to-track seek: 0	#milliseconds
drivedata: 0

8 partitions:
#      size      offset  fstype   [fsize bsize bps/cpg]
    c: 160086528     0    unused     0     0     # (Cyl. 0 - 9964*)
/kernel: ad6: cannot find label (no disk label)
/kernel: ad6s1: cannot find label (no disk label)

#end of output

Many thanks for your help.


More information about the freebsd-questions mailing list