Disklabel problem IBM SCSI3 disks, vinum too

Bob Collins freebsd at anything-inc.com
Sun Nov 23 10:08:27 PST 2003


At 07:30 PM 11/21/2003, you wrote:
>[Format recovered--see http://www.lemis.com/email/email-format.html]
>
>Quotation broken.
>
>On Friday, 21 November 2003 at  9:25:58 -0500, Bob Collins wrote:
>> At 08:41 PM 11/19/2003, Greg 'groggy' Lehey wrote:
>>> [Format recovered--see http://www.lemis.com/email/email-format.html]
>>>
>>> Quotation broken.
>>>
>>> On Wednesday, 19 November 2003 at  9:13:43 -0500, Bob Collins wrote:
>>>> At 10:46 PM 11/17/2003, Greg 'groggy' Lehey wrote:
>>>>>
>>>>> Do you have device nodes for da4?  Has it been labelled at all?
>>>>
>>>> I did not have `all' the nodes for da4 in /dev. So, I ran #sh MAKEDEV da4
>>>> in the /dev directory. After that, there were what appeared to be all the
>>>> device nodes for da4.
>>>>
>>>> I was able to label the drive and use it with vinum under
>>>> 5.0-RELEASE FWIW.  Under 4.9-RELEASE (which is what I now run) it
>>>> will not label through /stand/sysinstall.
>>>>
>>>> I can now newfs the drive and mount it and copy files to and fro,
>>>> however I cannot use it with vinum. I did umount the drive and
>>>> then disklabel -e da4 and changed the e: to h: and the filesystem
>>>> type to vinum. It was da4s1e.
>>>>
>>>> When I create the vinum configuration, I either get that drive d
>>>> (da4s1h) is referenced and in the down state while the other three
>>>> drives are up, or the other three drives a b c are referenced and
>>>> in the down state while drive d is up.
>>>
>>> I need the information I ask for in
>>> http://www.vinumvm.org/vinum/how-to-debug.html.
>>
>> FreeBSD 4.9 RELEASE
>>
>> No changes to sources
>>
>> vinum -> list
>> 4 drives:
>> D d                     State: up       Device /dev/da1s1h      Avail: 0/8747 MB (0%)
>> D c                     State: up       Device /dev/da2s1h      Avail: 0/8747 MB (0%)
>> D b                     State: up       Device /dev/da3s1h      Avail: 0/8747 MB (0%)
>> D a                     State: up       Device /dev/da4s1h      Avail: 0/8747 MB (0%)
>>
>> 1 volumes:
>> V raid                  State: down     Plexes:       1 Size:         25 GB
>>
>> 1 plexes:
>> P raid.p0            R5 State: init     Subdisks:     4 Size:         25 GB
>>
>> 4 subdisks:
>> S raid.p0.s0            State: empty    PO:        0  B Size:       8747 MB
>> S raid.p0.s1            State: empty    PO:      512 kB Size:       8747 MB
>> S raid.p0.s2            State: empty    PO:     1024 kB Size:       8747 MB
>> S raid.p0.s3            State: empty    PO:     1536 kB Size:       8747 MB
>
>This doesn't agree with what you say above.  It also looks fine to
>me.
>
>Greg
>--


My apologies, Greg. Quite right. I was messing with the system right before the response about sa4 device nodes in /dev. Once I made the da4 devices, then the disklabel worked. My mistake jumping the gun.

One follow-up question if I may.

I assume that the init process for a RAID5 takes quite some time, no? This has been in the init stage for 3 days. The vinum daemon is running as I can see it listed in ps -ax.

Thank you
Bob 



More information about the freebsd-questions mailing list