Vinum configuration problem (RAID-1)

Jani Reinikainen jani at
Thu Nov 20 01:53:05 PST 2003


I'm trying to setup Vinum on a FreeBSD 5.1-RELEASE box, according to the
instructions at, pages 236-240,
where the idea is to create one big Vinum partition which overlaps all
other partitions.

Basically, what I've done so far:

In disklabel, created swap first, so it gets offset 0, in the following

Part		Mount		Size
ad0s1b		swap		512m
ad0s1a		/		1024m
ad0s1d		/home		1024m
ad0s1e		/tmp		512m
ad0s1f		/var		the rest (6424401 blocks)

Booted into single user mode:

# mount -u /

# bsdlabel -e ad0s1

Shortened swap ('b' partition) by 281s:
- 1048576 (original size) - 281 = 1048295
- Changed offset 0 to 281

Created a new partition 'h':
- size = 12715857 ('c' partition) - 265 = 12715592
- offset 16
- type vinum

Thus, resulting in a bsdlabel output such as this:

# bsdlabel ad0s1
# /dev/ad0s1:
8 partitions:
#      size   offset  fstype
a:  2097152  1048576  4.2BSD
b:  1048295      281    swap
c: 12715857        0  unused
d:  2097152  3145728  4.2BSD
e:  1048576  5242880  4.2BSD
f:  6424401  6291456  4.2BSD
h: 12715592       16   vinum

Then, I created a config file for vinum like this:

drive YouCrazy device /dev/ad0s1h
 volume root
   plex org concat
     sd len 2097152s driveoffset 1048560s drive YouCrazy
 volume swap
   plex org concat
     sd len 1048295s driveoffset 265s drive YouCrazy
 volume home
   plex org concat
     sd len 2097152s driveoffset 3145712s drive YouCrazy
 volume tmp
   plex org concat
     sd len 1048576s driveoffset 5242864s drive YouCrazy
 volume var
   plex org concat
     sd len 6424401s driveoffset 6291440s drive YouCrazy

However, when I run:
vinum -> create -f /etc/vinum.conf

I get the following output:

vinum: drive YouCrazy is up
viunm: root.p0.s0 is up
viunm: root.p0 is up
vinum: root is up
vinum: swap.p0.s0 is up
vinum: swap.p0 is up
vinum: swap is up
vinum: home.p0.s0 is up
vinum: home.p0 is up
vinum: home is up
vinum: tmp.p0.s0 is up
vinum: tmp.p0 is up
vinum: tmp is up
vinum: var.p0.s0 is up
vinum: var.p0 is up
  16:         sd len 6424401s driveoffset 6291440s drive YouCrazy** 16
No space for
  on YouCrazy: No space left on device

I've tried this a few times, making sure my calculations are correct,
but I always get the same error. I suck at math though, so that might be
causing my problem :-P

I also tried using 4.9-RELEASE and UFS1, but that didn't help either.
Must be something obvious I'm missing. I'd appreciate it if someone
could please point me in the right diretion.


More information about the freebsd-questions mailing list