Kernel Panic on Install

Todd Kennedy todd at
Wed Nov 19 22:24:36 PST 2003


I'm trying to install FreeBSD 4.9 (from the Mini CD ISO) on my system, 
yet the instant it tries to load the driver for my ethernet card, it 
has a Fatal trap 12.

I read the FAQ on this and searched the mailing list.  Unfortunately, I 
can't do a stack trace or provide anymore information than what the 
Kernel Panic says, but since it's the default 100% plain vanilla 
kernel, maybe someone can help me out.

The ethernet card is a 3COM Fast Etherlink XL PCI (3C905B-TXNM), and I 
noticed that the fault might be from failing hardware, (the hardware 
does work under XP, but I know that's not  100% tried and true test), 
so I swapped it out with my other ethernet card from my linux server 
(same exact ethernet card, and it works under Redhat 9 and Debian 
Woody) and I still get the same error message.  (Of course it might be 
other hardware failing, but the system does work fine under XP).
The last kernel messages before the panic are:

4.3 on pci0
xl0: <3Com 3c905B-TX Fast> at device 10.0 on pci0
xl0: couldn't map ports/memory
xl0: reset didn't complete
xl0: command never completed!
xl0: command never completed!
xl0: command never completed!

Then it prints out:

Fatal trap 12: page fault while in kernel mode
fault virtual address = 0x0
fault code = supervisor write, page not present
instruction pointer = 0x8:0xc03156bf
stack pointer =  0x10:0xc084be10
frame pointer = 0x10:0xc084be38
code segment = base 0x0, limit 0xfffff, type 0x1b
	   		= DPL 0, pres 1, def32 1, gran 1
processor eflags = interrupt enabled, resume, IOPL =  0
current process =  0 (swapper)
interrupt mask = net tty bio cam
trap number = 12
panic: page fault
Uptime: 0s

The system is a P3-666 with 512MB ram, on an ASUS motherboard.  If 
anyone has any ideas as to what could be causing this, or what other 
things I might try to prevent this from happening that would be great.



More information about the freebsd-questions mailing list