GDM - configured as per the documentation but stil chrashes - FreeBSD 4. 9 an d 5.1

martin.clausen at martin.clausen at
Mon Nov 17 13:23:17 PST 2003

Thanks for the input. Actually I got it working on 4.9 by renaming to It seems that gdm has to be the last thing program to launch at boot time.



Lowell Gilbert <freebsd-questions-local at> wrote:
> martin.clausen at writes:
> > I cannot get GDM2 to work on neither 4.9(nor 5.1.)
> > 
> > GDM chrashes at boot time no matter what I do.
> > 
> > I use the gnome2-2.4.0 package. I have tried to install it
> at install time(which results in the gdm users not being
> created), installed it afterwards and compiled it from
> source(using ports), but the result is the same: gdm
> chrashes X at boot time.
> > 
> > I have followed the instructions given at package install,
> that is copied the /usr/X11R6/etc/rc.d/ to
> /usr/X11R6/etc/rc.d/ I have also copied the
> /usr/x11R6/etc/gdm/factory-gdm.conf to
> /usr/X11R6/etc/gdm/gdm.conf. I have not touched the
> /etc/ttys file, it is vanilla as installed.
> > 
> > I have searched the net in vain for any tips on how to fix
> this, the only things I have found are the ones I have tried
> already. The pam fix(from
> > ) should not apply to 4.9 so I have not treid that.
> > 
> > Any help would be greatly appreciated.
> Try starting not starting gdm at boot, and kicking it off
> later.  This
> will enable you to get a better view of what breaks.  You
> should also
> look at the gdm logs, and possibly the X logs.  
> Personally, I use xdm, so I don't have much help specific to
> gdm.
> However, you might try xdm to see if the problem is with gdm
> or more
> directly related to X.

More information about the freebsd-questions mailing list