HP JetDirect EX printer problems ...

Alex de Kruijff freebsd at akruijff.dds.nl
Thu Nov 13 16:14:59 PST 2003

On Wed, Nov 12, 2003 at 05:13:06PM -0500, David Bein wrote:
> Hello ...
>   I have an older J2383 Jet Direct box which I am trying to setup
> for a FreeBSD 4.9/x86 box. I have tried various things in /etc/printcap,
> but still I get nothing reasonable. I know the box is working because
> if I telnet to port 9100 on the Jet Direct and type in some lines
> and then quit out of telnet, it prints them. So my problem is not
> the hardware or network connectivity.

There are two senerio's.
1. You have a post script printer. In this case you should be able to
send post script files directly to the printer daemon without having a
filter in betwain.
2. You have a non post script printen. In this case you proberbly can
send plain text files to it. The dos format will print fine and the unix
format result in the first line being printed fine and the rest continue
with a offset.

I'm one of those person in senario 2 and print my files though the
apsfiler to make the format right before sending it to the filter. This
is my printcap:

# APS1_BEGIN:printer1
# - don't delete start label for apsfilter printer1
# - no other printer defines between BEGIN and END LABEL
#    :lp=:\
#    :mx#0:\
#    :sh:\
# APS1_END - don't delete this

>   I am confused about whether this should be "lp=<port>@<host>"
> with appropriate filters or some variant of "rm=<host> rp=TEXT".
> None of the software examples I have seen appear to reference port 9100
> and so I am confused as to how it knows what to connect to except
> in the <port>@<host> configuration. Neither of these approaches worked.
>   I am wanting to use this with an old LaserJet 4L PCL class printer.
> Directly connecting it to a parallel port works just fine [using
> apsfilter
> and all the other Postscript conversion software]. I just want to have
> it work from whichever machine using the network both for reasons of
> speed
> and not wanting to have a single box up just to print from some other
> machine.

Check if you can print the defaul format. If you can the you have a
misconfiguration is the apsfilther.


Articles based on solutions that I use:

More information about the freebsd-questions mailing list